Jump to content

Downloads blocked as unsafe


Recommended Posts

spacer.png

 

I notice that downloads have stopped over the last 24 hours, possibly due to the above message.

Is this a site certificate issue by any chance? This error doesn't appear when downloading from other sites.

Tim Wright "The older I get, the better I was..."

Xbox Series X, Asus Prime H510M-K, Intel Core i5-11400F 4.40GHz, 16Gb DDR4 3200, 2TB WD Black NVME SSD, 1TB Samsung SATA SSD

NVidia RTX3060 Ti 8Gb, Logitech Flight Yoke System, CH Pro Pedals, Acer K272HL 27", Windows 11 Home x64

Link to comment
Share on other sites

Modern browsers have many paranoid security measures that can block perfectly safe files - a date discrepancy between your computer and the server, an expired or misread certificate, a reported file size that doesn't match the download, etc.  Firefox, and the d/l manager I use, give options to download/accept the file anyway.

 

Possibly those folks behind the screen have tweaked something which now causes this;  we're still waiting for file searches to behave and links from other sites to stop reporting "oops, we can't find that".

  • Like 1
Link to comment
Share on other sites

  • Founder
3 hours ago, cj75s said:

Still happening in Firefox today 16th Feb 24! Must be the site or all the files are affected by virus. Maybe Flightsim has been hacked?

Just a thought.

 

This sort of thing has happened before. More than likely, the cause is an upgrade to your browser, to Windows, or to some other security software you are using.

Link to comment
Share on other sites

39 minutes ago, Nels_Anderson said:

This sort of thing has happened before. More than likely, the cause is an upgrade to your browser, to Windows, or to some other security software you are using.

 

I'm only seeing the malware warning on downloads from flightsim.com, downloads from other sites are fine - this is with MS Edge browser.

  • Like 1

Tim Wright "The older I get, the better I was..."

Xbox Series X, Asus Prime H510M-K, Intel Core i5-11400F 4.40GHz, 16Gb DDR4 3200, 2TB WD Black NVME SSD, 1TB Samsung SATA SSD

NVidia RTX3060 Ti 8Gb, Logitech Flight Yoke System, CH Pro Pedals, Acer K272HL 27", Windows 11 Home x64

Link to comment
Share on other sites

Same here, but with Firefox.  If the issue were at my end I would expect problems at other sites also.  (It's not a major problem for me, just two extra clicks - open the menu and accept the d/l.)

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...