Jump to content

Carenado Piper PA-31 Navajo - glitch


Recommended Posts

When I loaded this plane recently the GPS was off. All other navaids and instruments were OK but the ON/OFF switch on the GNS530 does not operate. I have searched all the knobs and switches in the cockpit, just in case there was master switch hidden away somewhere. No luck. The failure of this 'switch' has survived reboots.

Previously the GPS was ON whenever I started (not starting from cold and dark at present). What have I missed?



Link to comment
Share on other sites

If you've changed your default flight to this aircraft, try changing it back again to the FSX default:

In the [uSERINTERFACE] section of the FSX.cfg file, look for the line beginning with "SITUATION=" and delete everything after "SITUATION=" then save and restart FSX.

Tim Wright "The older I get, the better I was..."

Xbox Series X, Asus Prime H510M-K, Intel Core i5-11400F 4.40GHz, 16Gb DDR4 3200, 2TB WD Black NVME SSD, 1TB Samsung SATA SSD

NVidia RTX3060 Ti 8Gb, Logitech Flight Yoke System, CH Pro Pedals, Acer K272HL 27", Windows 11 Home x64

Link to comment
Share on other sites

Right-click on the on/off knob/switch?? Use the scroll wheel on the mouse as you hover the mouse pointer on the switch?? More often than not, it's more than a simple left mouse-click.

Still thinking about a new flightsim only computer!  ✈️

Link to comment
Share on other sites

Thanks all, just to be sure that I was following advice I took the aircraft to an airfield I never use, saved this as the default. Closed and restarted FSX - so no question of a flight plan being loaded.

Tried both left clicking and then mouse wheel over the button. Zoomed right in and tried both centre and side of the button. Lots of turns on the wheel! Zero response.


Perhaps I should reinstall the Navajo?



Link to comment
Share on other sites

That's the opposite of what to do.

You should not have an old flight saved as startup flight.


Restore the default start up flight. To do so:


-close fsx,

-open the fsx.cfg file,

-change the line:

situation='whatever it says there'



-close and save the fsx.cfg file


-start fsx

the plane you will see as startup plane is now again the default flight ultralight.

-select your plane, location, time, weather, and click "Fly Now".

Link to comment
Share on other sites

A bit daft of me - given the context I read 'flightplan' for 'flight'! OK I've done it properly now. The only change since deleting the end of the line after SITUATION= is to reduce the framerate to 1.5 fps and the response time to a key press to 3 to 5 seconds. Everything unflyable.

Still nothing doing on the GPS - when I finally got there through Main Panel

The only alteration I made was to that one line.



Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...