Jump to content

FS2004 crashes when zooming out on GPS


Recommended Posts

I thought this error may have had to do with the computer's performance (it may still be that), but I did specifically pinpoint the last chain of the crash to be when zooming out on the GPS to 150nm. I also noticed FSrealWX had stopped working when the sim crashes, although the issue was replicated without it active.


Crashes occur at the airports tested with or without an IFR flight plan. Oddly enough, I was able to fly 3R3-RWV yesterday just fine (old Austin Executive Airpark). Maybe I didn't zoom out all the way, by luck? (verified; still crashed. It's a short route so I likely didn't ever zoom out that far).


Tried different flight plans (DFW-JAX, DFW-AUS, DFW-ORD, high-altitude routes on all). Attempted a direct route DFW-ORD, all crash.


Tried same DFW-JAX route, high-altitude on the default Cessna, crash observed.


Tried different origin point, AUS-ORD, still crashes.


Tried SEA-ORD, no crash observed.

Tried SFO-LAX, no crash observed.

Tried MEM-DFW, crash observed.


I'm noticing when spawning in airports in the central time-zone they crash.


Tried ATL-DFW, crash observed.


Ok so that didn't prove my point.


Tried SAN-SEA, no crash observed.

Tried DEN-PHX, no crash observed.

Tried SLC-ELP, no crash observed.


Pacific and Mountain time zone airport origins do not crash the simulator.


Tried DTW-CLE, no crash observed.




Tried CLE-BNA, no crash observed.

Tried BNA-FLL, crash observed.

Tried DAL-ORD, crash observed.


Whether or not addon scenery was installed did not make a difference.


Attempting DFW-JAX after having spawned in SLC for the route crashed the sim immediately upon spawning (GPS was at 200nm).


So it seems certain origin airports regardless of aircraft crash the simulator when zooming out, sometimes high-altitude, sometimes direct. It cannot be precisely singled out, but it does have something to do with the simulator.

Edited by TheRedBadger
Carlos Si
Link to comment
Share on other sites

This could be a corrupt fs9gps.dll in the Modules folder - sometimes a panel or aircraft comes with the FSX version which is also named fs9gps.dll. If you have a backup, from a few months ago just to be safe, try replacing the fs9gps.dll module.

Tim Wright "The older I get, the better I was..."

Xbox Series X, Asus Prime H510M-K, Intel Core i5-11400F 4.40GHz, 16Gb DDR4 3200, 2TB WD Black NVME SSD, 1TB Samsung SATA SSD

NVidia RTX3060 Ti 8Gb, Logitech Flight Yoke System, CH Pro Pedals, Acer K272HL 27", Windows 11 Home x64

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...