Jump to content

FSX won't install in Windows 11.


Recommended Posts

New Dell XP 8950. Windows 11. I have the original FSX discs, Product key etc. as I purchased FSX when first released. It installed fine on my Windows 10 system.

Now trying to install on Win 11. Disk 1 runs fine until it gets to a small window stating, "Removing Applications" It stalls here at about 25% on the slider type installing notice. It then stops. "The reading disk light" stays on but nothing else happens. The discs are not worn, scratched or anything as they have only been used twice previously and kept in the original package. The desktop stays black except for the installing notice.


Any ideas what to do here. I have Win 11 Pro on the computer.

Link to comment
Share on other sites

On 8/5/2023 at 2:39 PM, mrzippy said:

How long do you let it run while in the "removing applications" mode?  Some have said it takes quite a while for it to do it's thing!

Can agree.  Installed FSX on Win11 machine last week.  Ignore the message and go have a cup of coffee, take a bath, watch the news, etc.  My wait was only 20 minutes, but I've had other say they hit an hour.

  • Thanks 1

Ernest Pergrem

System: i7-13700K, Gigabyte Z790 UD AX, 32GB RAM, GeForce GTX 1080 FTW Gaming, Windows 11 Pro 64-bit, MSFS 2020, FSX, Thrustmaster T.16000M Joystick, Cessna Pedals, Saitek Trim Wheel, Switch Panel, and Multi Panel

Link to comment
Share on other sites

Okay installed and fly's. Two problems. (BTW it took about 30 min to load the program as you folks advised.)

1.No scenery except basic colors of the ground. No buildings, roads etc. nothing.  I have not yet installed additional scenery. Only the default at present.

2. No cockpit sounds. No external sounds. If I fly a tutorial the instructors voice is heard fine.

3. Not a problem exactly but how do I turn of that darn background music?


I have set this up exactly as my Windows 10 system was (still is).  The problems are on Win 11. As my sound bar is operated simply from a USB connection I have to use headsets plugged into the Nvida headset jack.


Any ideas or help appreciated. Joystick works fine

everything else seems fine with the exceptions listed.

Link to comment
Share on other sites

Go and right click your speaker icon inside your system tray. Then open up ‘sound’ then select ‘communications’

Then make sure your setting is set to ‘do nothing’ so windows can not reduce your sound levels.

Still thinking about a new flightsim only computer!  ✈️

Link to comment
Share on other sites

My Zippy.

Right click the speaker icon in the tray as you stated. Beyond that I get 2 choices "Open volume mixer" or "Sound settings" Neither of those gives me the choices you mention.


Can you help with the absence of  scenery?


Sorry for the delay in answering you. Have been tied up someone this past week  or so and do not get back to FSX every day.



Link to comment
Share on other sites

On your Settings Page  Make sure you have the sliders at least like I have.  Turn off the music by clicking where the arrow points.  In the 2nd pic, click where it's circled and maybe that will activate your sounds.


Screenshot 2023-08-17 4.00.56 PM.jpg

Screenshot 2023-08-17 4.04.34 PM.jpg

Still thinking about a new flightsim only computer!  ✈️

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...