Jump to content

New FSX DVD install goes black on choosing "fly now"


Recommended Posts

New user, new PC, new install of FSX - thanks in advance for having me. That said:


I have a new PC as follows:


Intel® Core™ i7-9700K (not overclocked)

Intel® Z390 chipset


MSI NVIDIA GeForce RTX 2070 8G Video

Direct X 12 (alogn with DX 9, see below)

Windows 10 Home 64 bit (17763.615)

C: - 500 MB SSD for Windows Only

D: - 2TB HDD for programs

FSX installed from original old DVDs in D:\Program Files\Microsoft Games\Microsoft Flight Sim X

- Yes, I created a dummy folder in D: for my games to install them on the D: HDD rather than C: with Windows, but I do plan to reinstall to the root of D:\ for efficiency after reading the forums (after determining what's causing my black screen issue) .


Starting FSX with "Run as Administrator" the program starts fine, even displaying the rotating trike under "free flight" and playing music. However the moment I click "Fly now", the screen goes black; music continues to play. FSX does nto appear to respond to any key combination, but windows responds to alt-tab and ctrl-alt-del. Task manger shows FSX not responding and if I choose sign-out after pressing ctrl-alt-del, FSX will close and allow me to sign out. Waiting a few minutes does not make a difference, so I am fairly certain it is not loading very, very slowly.


I have manually installed, per what I've seen in the forums:

Visual C++ Redistributable 2005, 2008 & 2010

.Net Framework v3.5 & v4.0

DirectX 9 (not sure how to verify that I have both versions installed)

FSX Service Pack 1 (verified as version

I have set HIMEMFIX in fsx.cfg

I have tried two different monitors, one Display port, one HDMI. I have turned off everything in the NVida Control panel and set FSX to minimum settings. Several other games did install and run great.


Any suggestions to move forward with the DVDs -or- any chance that purchasing the Steam versus would run any better?



Link to comment
Share on other sites

Thanks il88pp & Mrzippy so far.

@MrZippyI did install the FSX SP2 and the "Preview DirectX10" checkbox now appears.

@il88pp - Rebuilding the fsx.cfg did not make a difference, before or after SP2.

Next step I'm trying is a system recovery on Windows (since I so far had only the FSX DVD and some other Steam games installed) and trying the install again fresh. I'll let everyone know!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...