Jump to content

Unable to initialize FSXSE

Recommended Posts

"Flight Simulator was unable to load some program files and will now exit. Please reinstall Flight Simulator to restore or repair the program installation."


Nothing new has been added. I removed the program and reinstalled it. Same message. Any ideas?

Link to comment
Share on other sites

Ideas? sure...


1. read that "Help us help you" sticky just a bit above your new post. ( you're not a nooby anymore)

2. Have you checked your windows error logs to see if windows documented the failure. If it were me, I'd flush all the logs and then create the problem again... should be easy to find the log entry.

3. Have you tried the most common fixes (other than the reinstall/repair which you already did): rename or move your FSX.cfg and your Logbook.bin (to the desktop perhaps) and try to startup again.

4. Valve/Steam did a few modification to FSX. Have you searched for a solution on the Steam site and sought assistance there also?

5. "nothing new has been added", you said - perhaps something is missing.. like the C++ runtime files.

6. what are you running on - 7, 8 10? Perhaps it doesn't matter. Probably doesn't, since FSX runs perfectly well for most people on all platforms, but...

7. I infer that you've been running it ok and that the problem is new. This isn't your first STEAM install that's failed is it? If it is, does your equipment meet the minimum requirements for cpu and video?


Help us help you...


Edited by llivaudais

Hooked since FS4... now flying:

self-built i7-4790 at 4 GHz; GA-Z97X mobo; GTX 970; 16GB gskill;

quiet, fast and cool running.

Win 7/64: 840 EVO OS; 840 EVO (500G) game drive;

Win10/64: 850 EVO (500G) for OS and games

A few Flightsim videos on YouTube at CanyonCorners

Link to comment
Share on other sites

Did you verify your game cache?


To verify your game files please do the following:


1. Load the Steam platform and log into your account

2. Click the Library tab in the menu at the top of the screen

3. Click the List View from the view options on the top right of the screen

4. Right click on Microsoft Flight Simulator X: Steam Edition to bring up a popup menu

5. Click on Properties from the popup menu to bring up another popup box

6. Click on Local files from the popup box menu

7. Click on Verify integrity of game cache from the Local file options

8. Wait for the progress bar to finish verifying your files. Additional files may download

9. Restart Steam

10. Restart Microsoft Flight Simulator X: Steam Edition

Still thinking about a new flightsim only computer!  ✈️

Link to comment
Share on other sites

Done all of the above. Sorry about not being specific with computer specs. I panicked. I think I MIGHT have found the answer. I have a 4 day weekend so I'm going to try it all out and if I do have the answer, I'll report back here with what I did. Wish me luck, I need some aerial stress relief!
Link to comment
Share on other sites

I'm not really sure what happened, but either the Nvidia drivers screwed up after the latest Winblows update or the card puked it's guts out. A reset to original condition didn't work. The Geek squad will figure it out. I used to rebuild my own computers and learned how to do that JUST for flight sim, but I'm too old for that now. I just hope I can remember my passwords to get Steam and all my downloaded content back. I was really enjoying the Carenado 172n!
Link to comment
Share on other sites

Complete reinstall of WinBlows 10... God I miss Win98se! Spent two days reloading all of my addons and figuring out how to redownload payware.

Then organizing and backing up everything I reinstalled. This weekend will be spent trying to get the smoothness and performance I was getting before The Great Crash of 2019..

According to the Geek Squad, the recent Win10 update didn't install correctly causing a cascade of problems. It seems that pilot error brought the final downfall when I tried to reload Windows from the backup file, and it just further screwed things up and failed to fully install.

So the lesson learned is:

Get the damned thing running right, then leave it alone! It just pestered me about the update until I said "what the hell" and hit the button.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...