Jump to content

Product Activation Error Windows 10


Recommended Posts

I had to reinstall windows on my laptop. Then reinstall FSX gold. After install FSX I get a Product Activation Error. I did do a repair but it is the same error.


I saw in the event viewer Flight simulator was successfully installed.

I have FSX Gold since 2010 and never had any troubles.

I include a picture of the registry. Maybe you will see something that may solve this issue.

I miss my flight simulator.




Link to comment
Share on other sites

1. run regedit (Windowskey +R)



3. After you find the folder, double-click Upperfilters on the right side.

4. Change the value from 0 to PartMgr and/or remove any other settings and then click OK.

5. Close Registry Editor

6. Start FSX/Accel and you should get the registration wizard.



It looks like your PartMgr is missing the capital P and M.

Still thinking about a new flightsim only computer!  ✈️

Link to comment
Share on other sites

I uninstalled FSX and start all over. With the disk 1 there was an error reading the disk. Then I copy one by one file & folders to my D: drive and made sure the size of the file is the same as the copied one.


I then hit DVDCheck.exe and it start the installation. I waited until it ask for disk 2. But it first want D2Feat-10.cab. I then copy al the D2*.* files to the folder from Disk 2. It went on with the installation and then ask for Disk2. I insert the disk in the dvd drive but it would not except it. I then copy all the other files except for the DVDCheck.exe from disk 2 to the folder and wait.


A little later the installation finish with the message installation was successful. It open FSX and the activation window came up and was activated successful.


So without editing the registry FSX is now installed and running. I did a four hour flight and all went OK.


Thanks for the help but I solved it in another way. Maybe there is someone who can follow this procedure and install it successful.



Link to comment
Share on other sites

  • 1 year later...
Hi Mrzippy. I did what you suggest but it did not solve the error.


I have updated to a predator, seems since i installed steam all my 'non' steam self purchased games have issues. It was driving me insane not having my fsx deluxe.. I tried several things.. in the end it was the registry key.. simply using a capital P made the difference for me. Hope it helps someone else.. (oh and ALWAYS do things as administrator)



Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...