Jump to content

Switch and Multi display panel problems

Recommended Posts

ok, where do I begin..


I have installed and was running fine the multil switch panel and the Multi display panel..


I installed the Saitek X52 system and now they dont work...sounds like a simple solution...unintstall the X52 and see

if the two panels function again...they don't..

I have uninstalled the panels...rebooted, x52, rebooted, the Yoke rebooted....everything...see what the system finds, it saw everything but the X52 system....but still no panels.....updated all drivers from their source websites..

I have swapped around the USB plugs and devices to see if its an Interrupt issue...no joy


All diagnostics report the that panels are working properly..


During the boot sequence, the panel lights up...then go back out again...None of the switchs on either panel work..


every once in awhile the puter "pings" the display panel...it lights up ...then off again...


any ideas ???

Link to comment
Share on other sites

A little surprise there's no reply yet...

Strange that after reinstalled and updated it still no connection.

I suspect you are using the Saitek software for your panels.

Did you try using SPAD for your panels instead ? Work very well for many of us.

It is normal that multi and radio panels "flashes" while system boot up.

i7-4790K @4400 on Gigabyte Z97X (16gb), GeForce GTX 970 OC, Corsair Spec case

Win7 Ult(64) on Samsung850 SSD(256), FSX+Accell on Samsung850 SSD(256), Track IR5

Saitek yoke/rudder radio/multi/switch panels, Logitech G13, GMap on Samsung tab

Link to comment
Share on other sites

  • 2 weeks later...
Since I have got windows 10, the panels do not work, something to do with Win10 power management.

There is a YouTube video talking about this but it requires mr playing around with config files and I am not confident to do that yet.


Thanks for tips

One thing scientists do is to find order among a large number of facts, and one way to do that across fields as diverse as biology, geology, physics and astronomy is through classification. Alan Stern
Link to comment
Share on other sites

I've the X52 Pro and never been able to get the MFD working in Win10 even though there is a utube vid seemingly demonstrating it and I've tried the configs exactly. I've tried all the forums for all the ideas but to no avail. I had hoped owners Logitech may have updated suitable drivers but that doesn't seem to be the case.
Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...