Jump to content

re-installation problems


Recommended Posts

I recently did a full re-install of FSX on a computer built for and dedicated solely to FSX. I then installed third party scenery and airports (but not all airports that I had in the previous installation). Then I reinstalled Aerosoft A320/321 Everything ran reasonably well for a while and then quite suddenly: bits of the A320 went AWOL so that I could see through the ‘plane, then whole sections went missing followed by spot views becoming invisible (except for shadow when on the ground). Soon after, scenery started deteriorating with almost total degradation of landscape and loss of many airport features, including taxi- and runway markings.

What should I make of this? Have I overloaded memory or the video card, do I have a software clash? Not sure where to start on sorting this out. FSX is not usable at present.


PC spec: Intel i5-4690K CPU @3.5 GHz


NVIDIA GeForce GTX90 video card

64 bit OS


All advice welcomed.



Link to comment
Share on other sites

Thanks. I will take it carefully - having done one reinstall I don't look forward to doing another. But if I have to re-install FSX do I also have to remove all the add-one scenery and airports as well before running the re-install, or is it just FSX itself that needs to be removed and reinstalled?



Link to comment
Share on other sites

Right, I had a short session with FSX. removed all fsx.config files and flew Cessna. Plane flew fine but scenery looked terrible (two runways side-by-side at my home airport -Liverpool) and lots of ground markings missing around airport. Flew to Hawarden where again the taxi-way marking were missing, but airport buildings - which I expected to be default - all looked very good. Airbus Industries factory and hangar etc which I'm sure can't be default, yet I have not installed airport here, only N.England and N.Wales scenery. Not sure how to turn off added scenery.

Then tried the King Air; hopeless, wouldn't take off but careered around the airport on the ground and through the buildings. It responded to none of the Saitek controls. As it happens my joystick (for A320) is plugged in and King Air rudder moved in response and slewed aircraft on ground (but nothing else).

Looks like I'm close to the last resort of a re-install. This is too much work at present - need to deal with the rest of my life!

Is there anything else I can try at this stage?



Link to comment
Share on other sites

removed all fsx.config files and flew Cessna.

You removed the correct FSX.cfg file, yes? Not the one in the main, or root, FSX folder, like for example C:\Games\FSX, but the one in C:\Users\\AppData\Roaming\Microsoft\FSX folder? That's a pretty common mistake...


yet I have not installed airport here, only N.England and N.Wales scenery. Not sure how to turn off added scenery.

Go to Settings>Scenery Library menu. Search down through the list shown until you find the scenery folder you want to disable. Highlight it with a left click, then click on Delete Area from the menu. Or just click the little box with a check mark in it, beside the scenery folder's name in the list, and lclick it to make the check mark disappear. Click OK to exit, and let the scenery databases rebuild.

If it's not there, close FSX completely, go to the FSX\Addon Scenery\Scenery folder, and look for any .bgl file with the name of the airport(s) giving you problems, and move them to a back-up folder, or just delete them. Restart FSX and see if the problems disappear.


Then tried the King Air; hopeless, wouldn't take off but careered around the airport on the ground and through the buildings. It responded to none of the Saitek controls.

Sounds like whatever flight you saved off as the default, the plane's Autopilot was left on. But when you delete the correct FSX.cfg file, it will restore the original, default default flight, so to speak. The trike over Friday Harbor. Leave that as the default flight. THEN go try the King Air.

Make sure you calibrate whatever device you use for control, before you go flying. Saitek yoke, joystick, whatever. Check to see that the desired control device is showing in the Settings>Controls menu.

Whenever you get a situation like this, where you can't seem to control the plane, once you're in the world, click Z, and listen for the Autopilot Disabled tone. If you don't hear it, click Z again, until you hear the tone. Once you do, go to Spot view, and see if the controls move with stick. If the rudder won't move, but the rest do, try hitting CTRL+D, and see what happens.

Try trimming the pitch up a bit, say two to four degrees, before you start your take-off run. A lot of planes won't lift off unless you do. Be ready to trim it back down once you start flying, or you can stall and crash on the end of the runway :D

Same for the correct flaps setting. Most planes will need at least one or two clicks of flaps to lift off. And the pitch trim, of course.


Hope something in there helps a little...



Had a thought...then there was the smell of something burning, and sparks, and then a big fire, and then the lights went out! I guess I better not do that again!

Sgt, USMC, 10 years proud service, Inactive reserve now :D

Link to comment
Share on other sites

  • 2 months later...

At last I have got around to doing a full reinstallation of FSX. On launch I get the message 'SCENERY.CFG file.error.Local scenery directory (Scenery\EGBB\SCENERY) in scenery area 1.30 not found. Click OK to continue'. Continuing after this message seems to create no problems. Is it anything I need to attend to?


Progess to date - default aircraft flywing well and I've loaded some add-on airports OK. First trouble is with UK Night Scenery (almost stopping the action). So I'm going to remove this and see if default aircraft are OK again. A bit odd because this particular scenery was absolutely fine in the last installation of FSX - combined with a very large number of weather, scenery and airport files.


I'm not hurrying - I want to get it right!



Link to comment
Share on other sites

I bit the bullet and did clean reinstall. If anyone can bear to read this long log and could help me, I'd be very grateful - it is so frustrating. I followed advice and at each step flew a default aircraft to make sure nothing had gone wrong with that step:

This is a clean reinstalled of FSX. My previous installation used a lot of additional scenery including, the Playsims VFR scenery for Southern Scotland, N. England and N. Wales, Eastern Ireland and South of England. Also, about 12 UK and European add-on airports. GEX Interface and Ultimate Terrain Europe, Rex Soft Clouds, Rex HD Worldwide Airports, Aerosoft Night Environment UK.

I mainly flew the Aerosoft A319/320. Without any warning everything went wrong – mainly the A320 and other aircraft becoming transparent and a general loss of smooth operations. Nothing was changed or added immediately prior to this that might account for loss of effective use of FSX.

This is a log of my reinstallation in March 2018, basically at each step I flew around in a defult aircraft to make sure that all was well:

Installed FSX

Added GEX interface and Ultimate Terrain Europe X

Installed EGGP/EGCC

Flew Cessna from EGGP– needed to reduce FSX realism setting to less than maximum (with acceptable results)

Installed EGBB and flew Cessna, poor scenery but realised that I had installed an older freeware version.

InstalledUK 2000 EGLL/EGKK

Flew around and between EGLL/EGKK

Returned to EGGP and:-

Noted that EGGP/EGCC airport scenery had deteriorated

Installed Rex Soft Cloud

Uninstalled EGBB and installed UK Scenery 2000 version

Good imagery of EGBB and flew around successfully

Installed Aerosoft Night Environment UK

Frame rate reduced to about 3 fps (note: this was excellent in the previous installation)

Uninstalled Aerosoft Night Environment UK

Flew around EGBB – all OK

Installed VFR scenery for N. England and N. Wales

Cessna flights OK

Installed UK2000 EGGP Xtreme

Again, flew Cessna, all OK

Launched GEX interface and Ultimate Terrain

Cessna flights OK

Flew King Air with various weather settings

Installed Aerosoft Koln-Bonn EDDK airport

Flew Cessna OK

Installed Dublin Int. EIDW with high res textures – all buildings black blocks

Reinstalled EIDW without high res textures – better but still some black block buildings

Returned to fly Cessna from EGGP – scenery very much altered for the worse

Uninstalled and reinstalled EGGP

Flew Cessna: scenery all wrong: some airport features missing, water around the airport, blocky colours for the Mersey.

Reinstalled EGGP (twice) no improvement.

Reduced scenery and weather to medium low settings – no change.

So I seemed to have reached a point at which scenery is misbehaving and no hope of progressing to A320. Loss of Night environment extremely annoying.


PC spec: Intel i5-4690K CPU @3.5 GHz


NVIDIA GeForce GTX90 video card

64 bit OS

Link to comment
Share on other sites

Well, let's see what we can do here....


First of all, you don't mention if you installed the UK2000 Common Library - that is a must for their scenery to work. I would assume you have it, but we have to be sure.


Second, you may have the sceneries in the wrong order of priority.


And third - and almost certainly - you have duplicated sceneries.


For managing your scenery and their priorities, you should get a utility called Scenery Configuration Editor (SCE), and to check for duplicated scenery you should get Jon "Scruffy Duck" Masterton's Simple Airport Scanner (SAS).


If you need links for these, then reply here, and I can send you the links tomorrow.



Link to comment
Share on other sites

Just to say thanks, Jorgen. As you suggested, I had duplicate files. Eveything seems to be OK now - though I'm still with default aircraft. May install Aerosoft A319/320 tomorrow.

A long day sorting it all out - but without your help it would have been even longer.



Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...