Jump to content

Elevator problem


Recommended Posts

First time I have ever encountered this. Just flew a short flight with a PA a321, RCSS to RCFN... about 2 minutes before touchdown I turned off the AP and hand flew to the runway - but the elevators were very unresponsive, as I neared the airport I could get very little up or down movement at all. I managed to control the descent and land OK using elevator trim (which worked fine), but the elevators themselves seemed almost frozen when operated with my Saitek X52.


At the gate I did a few tests - I tried the X52 Control panel utility, which showed that inputs gave full movement as I would expect. Changed to the default Cessna - for the first few inputs the elevators moved, though less than normal, but over the course of a minute, the elevator movement became less and less as I moved them up and down until it was hardly moving at all. (Ailerons and rudder were fine).


I unplugged the X52 and used the keyboard (NUM2 & NUM8) to move the elevators, but no difference: just the barest hint of movement up and down.


I closed FS9 and started it again. With the Cessna at least, the elevators are now moving normally with both the X52 and keyboard. But what might the cause be? - this may be the first time but I suppose if it's happened once it could happen again. Anyone else had this (and/or know a cure)?



Link to comment
Share on other sites

Its possible you may have had a bad connection from your yoke to your PC.

Outside of FS, just unplug then replug your controller into its connection. You should also try doing a re-calibration through Windows and not FS then try doing a re-cal from the menu in FS and note if the values look a lot different.


Sometimes calibrations can go wonky for odd reasons, it just happens. Its also possible that the sensor in your yoke has become mis-aligned but try doing a re-cal first.

Link to comment
Share on other sites

Thanks, but I did unplug the X52 and plug it back in again - I quite often have to do that (enough for me to have bought a short USB extension lead so that I can pull the connections apart right next to my mouse, rather than have to find the USB connection at the back of the PC!). That didn't help - the calibration is fine too (I do check that at intervals). Moreover, with the X52 unplugged the keyboard shortcuts, as I say, worked no better than the X52. Each time I reloaded the plane, the response was better (purely keyboard inputs), but with each entry NUm2 and NUM8, the movement got less and less.



Link to comment
Share on other sites

A couple of other things you might want to check:

In the A321, when you switch off the AP does it also switch off ALT and VS?

In FSUIPC, do you have any settings checked for elevator centring or other control movements/calibration?

Tim Wright "The older I get, the better I was..."

Xbox Series X, Asus Prime H510M-K, Intel Core i5-11400F 4.40GHz, 16Gb DDR4 3200, 2TB WD Black NVME SSD, 1TB Samsung SATA SSD

NVidia RTX3060 Ti 8Gb, Logitech Flight Yoke System, CH Pro Pedals, Acer K272HL 27", Windows 11 Home x64

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...