Jump to content

Fatal Error on FSX


Recommended Posts

Recently I've had a problem with a "Fatal Error" message when I start FSX and then the program shuts down. I've run a virus scan, a malware scan, a spy-bot scan, a chkdsk scan but nothing shows up. I tried a "repair" using the original MS X disc., which runs fine but does nothing for the problem. Looking at the Administrative event viewer, I see all error codes (1000) that indicate it is an fse.exe issue dealing with some dll files but I'm not sure how to correct them or interpret the codes involved. I suspect it may have had to do with driver program I had that did a "bulk installation" of drivers. However, I can't do a system restore because..1. The only restore point goes back a few days and..2. When I do run it I get an error message stating it didn't complete because of...error 0x0070091. I've also tried a complete removal and re-installation of FSX but to no avail. What might I be missing?? Thanks for any suggestions.


Prior to this, everything was A_Okay!!!




Intel i5 Kaby Lake 3.8Gz processor

ASUS Z270 Motherboard

Corsair 16GB DDR4 memory

WD 1 TB Hard drive

Samsung 500 Gb SSD

Window 10 Pro 64-bit

Nvidia 750 Ti video card

Corsair 750 watt PS

27" Sceptre HDMI monitor

24" Dell DVI monitor

19" Dell VGA monitor

Link to comment
Share on other sites

Do not reinstall. Do not use repair.

Google the name of the .dll in quotes, plus the word fsx, like so:

Google: "xxxxxx.dll" fsx


you are likely to find a solution.

The 'fatal error' is not as fatal as you may think. The install is not dead at all. It's just a program, crashing.

Link to comment
Share on other sites

Control Panel-> Administrative Tools-> Event Viewer, select Custom Views-> Administrative Events.

One of the listed events will be for your CTD. The "Faulting Module" should point to the problem area.


Tell us what the Faulting Module is! That will point us in the direction of the proper error, aiding in troubleshooting.





General Tab:

Faulting application name: fsx.exe, version: 10.0.61637.0, time stamp: 0x46fadb14

Faulting module name: This is what we need to Know!

Exception code: 0xc0000005

Fault offset: 0x0000ee3a

Faulting process id: 0x748

Faulting application start time: 0x01ce0253dc4b69d4

Faulting application path: R:\FSX\fsx.exe

Faulting module path: R:\FSX\window.dll

Report Id: 9caf77b4-6e50-11e2-8570-3085a99825d1


If there is not one listed:

Faulting module name: unknown, version:, time stamp: 0x00000000,

you will need to do as previously noted



No Faulting Module? ->

Remove all of the add-ons, and test the sim. If it works OK, then reinstall them one at a time and test.

Be sure to test each thoroughly before moving on to the next

Still thinking about a new flightsim only computer!  ✈️

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...