Jump to content

Joystick Problems after Installing NVidia 1070


Recommended Posts



Just installed a new Video card. Fired up FSX-SE. Great resolution and framerate. Saitek X-45 joystick acted funny like it needed to be recalibrated. Needed full right rudder to taxi straight in VRS Superbug. All other axis had similar anomalies.


Unchecked "enable" in FSX control. Checked to see if axis were assigned. They were not which is how I normally set up the X-45 with FSUIPC4.


Tried to calibrate in FSUIPC4. One side of each axis had normal values, but the other side had bogus values (ie. -16384 which would be normal and 5000). Well maybe I need to redo each axis. The only axis recognized was throttle and it wasn't right.


Tried reassigning axis in FSX (default). No change.


Tried same procedure on FSX default aircraft. No change.


Tried changing to another USB portfor joystick. No change. Other than the new video card, with HDMI vs. VGA previously, the only other change was the USB port. I lost the 2 front USB ports when the card was inserted. The X-45 was persnickedy about wanting one particular USB port and acted funny when I plugged it in elsewhere.


I'm confused and don't know what to do next. Anybody have any ideas?


System Specs:

Manufacturer: Hewlett-Packard

Model: 700-215xt

Form Factor: Desktop

No Touch Input Detected


Processor Information:

CPU Vendor: GenuineIntel

CPU Family: 0x6

CPU Model: 0x3c

CPU Stepping: 0x3

CPU Type: 0x0

Speed: 3392 Mhz

8 logical processors

4 physical processors

HyperThreading: Supported

FCMOV: Supported

SSE2: Supported

SSE3: Supported

SSSE3: Supported

SSE4a: Unsupported

SSE41: Supported

SSE42: Supported

AES: Supported

AVX: Supported

CMPXCHG16B: Supported

LAHF/SAHF: Supported

PrefetchW: Supported


Video Card: NVidia GTX 1070 8G memory


Operating System Version:

Windows 10 (64 bit)

NTFS: Supported

Crypto Provider Codes: Supported 311 0x0 0x0 0x0

Link to comment
Share on other sites

Problem solved!


Searched for "game controller". It sent me to Control Panel Game Controllers which said it was working fine. Selected "Advanced". Then "Calibrate". Calibrated the good old fashion way and Voila. Joystick works like a champ.


I seem to remember someone, a while back, saying that you should do a device recalibration when you switch USB ports. They were right. Case closed.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...