Results 1 to 8 of 8

Thread: Perfect Flight - Private Flights Beech Baron 58 For FSX & P3D no support

  1. Default Perfect Flight - Private Flights Beech Baron 58 For FSX & P3D no support

    Rarely, I purchase a product for my beloved FSX so I am by no means big time experienced at these things. I admit that. Well, over the Christmas holidays I grabbed the Perfect Flight - Private Flights Beech Baron 58 For FSX & P3D.. The instrument package failed to install so I basically ended up with a Baron plane with a new paint job.


    Dutifully I went to Product Support ( https://www.fs2000.org/product-suppo...efa9fd4ee11292 ) and gave the details. Considering that it was a holiday I expected a lag in a reply. Over days I sent 3 more requests, none of them nasty. Well, the holidays are over and I'm starting to think I made a mistake doing biz with said company.

    I have a belief that the fix is probably pretty simple...but I'm just guessing bekez all I'm drawing is blanks from "support." Seems like my support requests have all flown to Pluto. All I have left is to come here to complain and warn that you're evidently on your own if your purchase from this company turns into a boat anchor.

    I'd be happy to delete this comment if they'd get it in gear and help me per-fect my purchase.

  2. #2
    Join Date
    Jan 2012
    Location
    San Francisco, California
    Posts
    17,419

    Default

    Can you explain further where you said the instrument package failed to install.
    Mr Zippy Sent from my keyboard using "Whackamole", NudgeAKey + 2 Fingers

    Emachines T3418 AMD 3400+ processor 2GHZ/256KB L2 Cashe 2Gig Ram 160Gig HDD NVidia GEForce 6100 GPU Running WinXP Home Can't believe it still works! Running FSX Standard with SP1 and SP2

  3. Default

    Quote Originally Posted by mrzippy View Post
    Can you explain further where you said the instrument package failed to install.
    Hi... The dashboard installed...It's all black with insets for the instruments. But the instruments are missing. None. Zip. Just blank left side to right side. I looked around in the Perfect Flight files...found the panel inset graphics, but nothing with gauges. Of course, I'm not sure of what exactly I'm looking for. (Or what to do about it if I did find anything marked gauges.)

    The PF Baron comes in two versions...one which uses the standard instrument panel and what they call the 1000 which has their version...so the advertising says. The standard works with FSX instruments....the other is just el blanko.

    So happens the package comes with several other goodies which makes the thing a good deal....if everything works...which it doesn't. Other than the missing avionics, which is why I got it in the first place it's coolio. Can't say I'd recommend it now though since Imperfect Flight obviously folded up their tent and poofed on me.
    Last edited by RThorndyke; 01-09-2020 at 09:49 AM.

  4. #4
    Join Date
    Jan 2012
    Location
    San Francisco, California
    Posts
    17,419

    Default

    Was there an auto-installer which was suppose to install everything for you or was it all done manually? Can't believe there was no Gauges folder that needed to be installed to the panel!
    Mr Zippy Sent from my keyboard using "Whackamole", NudgeAKey + 2 Fingers

    Emachines T3418 AMD 3400+ processor 2GHZ/256KB L2 Cashe 2Gig Ram 160Gig HDD NVidia GEForce 6100 GPU Running WinXP Home Can't believe it still works! Running FSX Standard with SP1 and SP2

  5. Default

    Quote Originally Posted by mrzippy View Post
    Was there an auto-installer !
    I auto installed it. If the thing installed the instruments to the FSX folder..I wouldn't know what to look for. Except...all the dates match in there. Nothing new.

    There is a "panels" folder with the blank insets I was talking about earlier....but nothing marked gauges, instruments...none of that stuff like that is in the default folder.

    But in the PF folder, definitely no instruments. Everything else, seems like...but no instruments. And re-installing would be foolish. It just ain't there. I see a couple of .mdl files in the g1000 folder, whatever that is... At any rate, when the plane loads the instruments are missing.

    Which ought not to be the case if there is any common sense left. I was hoping, that instead of me having all these theories...that the seller would just send me the rest of it that is missing so I could stuff it into the folder, or tell me what to get it working if its there somewhere. But they seem to have moved on.
    Last edited by RThorndyke; 01-09-2020 at 04:11 PM.

  6. #6
    Join Date
    Jan 2012
    Location
    San Francisco, California
    Posts
    17,419

    Default

    I agree that the seller should respond back to you with some answers. I am wondering if that auto-installer needed to have your anti-virus protection turned off. Sometimes information is considered malware by your anti-virus and not installed with the rest of the download. I have tried installing some freeware aircraft and have had gauges declared malware and not installed.

    Just something to think about!
    Mr Zippy Sent from my keyboard using "Whackamole", NudgeAKey + 2 Fingers

    Emachines T3418 AMD 3400+ processor 2GHZ/256KB L2 Cashe 2Gig Ram 160Gig HDD NVidia GEForce 6100 GPU Running WinXP Home Can't believe it still works! Running FSX Standard with SP1 and SP2

  7. Default

    Quote Originally Posted by mrzippy View Post
    needed to have your anti-virus protection turned off.

    Just something to think about!
    That's just great advice MrZ. One of the first things I did was to go check McAfee. Sandbox and all. It's pretty good about warning that it's up to something and for sure logging what it did. Nothing there. So that doesn't seem to be the issue. Like I said I'm sure it's something dirt simple. The seller just isn't there. I'd hope that FlightSim would take note as they shouldn't be selling that which doesn't work or at least that which there ain't no support.

    The last thing I wanted to do was to come here complaining... (Gave Perfect Flight their chance with at least 4 support requests.) That in itself ought to get some action...but it hasn't....so let it be a warning. Steer clear of good old Perfect Flight.

  8. #8

    Default

    Personally I never use auto-install, I create an empty folder and install to that, then manually put the files where they should go, then you can also see if anything is missing etc, also you never know what files the auto are putting in and where.

    Col.

Similar Threads

  1. Perfect Flight - Beech Baron 58
    By Gunner44 in forum FS2004
    Replies: 0
    Last Post: 01-31-2007, 08:59 AM
  2. Perfect Flight Beech Baron 58
    By Gunner44 in forum FS2004
    Replies: 0
    Last Post: 01-28-2007, 02:55 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •