Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11

Thread: Saitek pedals not recognized by Win10?

  1. Default Saitek pedals not recognized by Win10?

    Hello all,

    I thought this had been covered, but I can't find anything in the forums. Since installing onto a Dell Alienware last spring my pedals have become an Unknown USB Device. Has anyone else had this problem? That's my main question. I'm wondering if they just need rewiring. They have itty bitty fragile wires inside. They have worked well for several years on my old Win7 system, and no I haven't tried plugging them into another computer. My next step.

    I thought I read where Saitek, now whoever, knew about the problem and weren't correcting it. I doubt the new owners even care. I can't install the drivers because Win10 and Saitek's install program don't recognize the device. Saitek never offered updated drivers. Any thoughts on the subject would be appreciated.

    My Saitek Pro Flight X-52 controllers have held up for years. My Saitek console (steering wheel and 3 levers) went out after about a year. I think the USB went out on it and I've never bothered to get it repaired. I'm thinking of going with some pedals of a higher caliber than Saitek.

    I'm glad to see the FSX community going strong. A big thanks to all the mission, scenery and plane developers who have kept me busy for hours trying to figure out what's going on, and to all of you fellow pilots.

    May the road never rise to meet you,

    Phil aka pcwildman
    Bell X-22A, revamped for FSX with PIGG HUD and Apache HUD, down for maintenance

    FSX SP2 with too many add-ons on a Dell Alienware Win10, i7-6700HQ 2.6 Ghz 8G ram GeForce GTX 970, with the sliders all on high, except in heavy scenery, for the first time in my FSX career. Yes!

  2. #2
    Join Date
    Feb 2010
    Location
    Denver, CO USA KAPA, KLMO, 35CO
    Posts
    1,950

    Default

    It's Win 10 that's the culprit; the Drivers (or lack thereof) don't recognize what the Pedals are supposed to do, hence the 'Unknown USB Device' warning. Win 10 has had issues in the past with recognizing certain types of Hardware, like HID's.

    Check the connections from the Circuit Board to the USB plug to see if anything pulled loose; if so, re-solder as necessary.

    I don't know if Logitech is planning to Update the Drivers, or make changes to them at all. Saitek was never very good with Drivers; most of the time they did more harm than good.

    Alan

    "I created the Little Black Book to keep myself from getting killed..." -- Captain Elrey Borge Jeppesen
    i5 M450 2.4/4GB RAM/ATI RADEON 5000HD 1GB GPU/500 GB HDD/WIN 7 PRO 64/FS9 CFS CFS2

  3. #3

    Default

    I am in Win 10 and the two drivers are there and functional (top left to right 1 & 2):

    Click image for larger version. 

Name:	Saitek.jpg 
Views:	146 
Size:	261.8 KB 
ID:	195292

    Cheers,

  4. #4

    Default

    I'm on windows 10 too and my Saitek pedals are working fine. I'd say try a different usb port.

    Cheers Stinger

    Sent from my SM-A300FU using Tapatalk

  5. Default Thanks

    Thanks Alan,

    That's pretty much what I expected to hear. I don't know why there's not more on this in the forums. I think I paid $120 for the pedals and now they're another doorstop. I'd sure like to know what other people are doing about it.

    Keep it up,

    Phil

    I wrote the above before seeing the other responses. Now I suspect there's a problem with the pedals. Thanks guys.
    Last edited by pcwildman; 12-14-2016 at 04:55 PM.

  6. Default

    This thread is about a different device, but it might give you some ideas:
    https://www.flightsim.com/vbfs/showt...t-win10-update

  7. Default

    Thanks il88pp,

    That thread lead me to the forum where I first read about the problem.

    Now I need to know if running the USB Enhanced Power Management Disabler could lead to knocking out the X-52 controls? And is it really necessary? I don't know that I even have Enhanced Power Management. It's not something I've ever seen in Saitek installs and I don't use a fancy array of panels- just the X-52 and the pedals.

    I'll keep hacking away.

    Ever confused,

    Phil

    It looks like the threads here are talking about Win8 and 8.1. The solution is to reinstall drivers, but I'm back to my original problem of USB Device not recognized. I can't install new drivers because the device isn't really there, and I don't think power management or USB level is the answer. There appear to be different problems with different Saitek devices among different computers. And they told us High Tech would simplify our lives.
    Last edited by pcwildman; 12-16-2016 at 04:04 AM.

  8. #8

    Default

    I have studiously avoided Windows 10 because I've heard so many "horror" stories from other simmers! So if it's a 10 issue, I have no knowledge.

    However as a Saitek user myself I have two suggestions which might help if the issue isn't with 10 itself.

    1. Go to the MAD CATZ site. They have better and more up to date drivers for Saitek devices than anyone I know. They also have a user forum dedicated to Saitek devices. You might find out about 10 there!

    2. Get a powered USB adapter and plug your device into that. If you're using more than one USB device at a time, you probably would benefit from having less voltage drag on your motherboard.

    Good Luck!

    Michael

  9. Default

    Thanks Michael,

    I have all the drivers, software and disks, they just don't help. Win10 is a mixed blessing. On the one hand, it's the best thing since XP, on the other it is the most invasive Big Brother is Watching OS ever. I went from 7 to 10. Many of the Kaspersky, and other AV programs, components can't do their job. You don't actually own it, it is now a license. And it doesn't want to recognize my pedals. I'd still highly recommend it. When FSX runs it runs beautifully and I've heard some good things overall from other Win10 users. The problems seem to come from disparate computers, components and software. My HP Spectre (SSD) runs better under Win10, and does more, than any computer I've ever had. I use it for everything except games.

    Now I know that other Win10 users had no problem with their pedals and I suspect mine need a wire reattached.

    The powered USB hub solved some other problems, but, unfortunately, not the pedals. They're still not recognized. I can't believe I never thought of the difference between powered hubs and plugging straight into the computer. I assumed there were plenty of amps to go around. Obviously, there aren't. I only recently starting reading about it. My window on my X-52 throttle now stays lit. I need to complain more, I'm learning about how to solve a bunch of other nit picky problems here.

    Thanks to everyone. I'll figure it out.

    Keep Flying,

    Phil
    SAR in the Beaver out of Sandspit

  10. Default

    I have no problems with the pedals, with FSX or XP-11beta. They're connected directly to the PC via USB, tht other Saitek bits use a hub. I installed the pedals while I still had Win7, then at some point installed FSUIPC. When I upgraded to Win10, the pedals were still recognized OK.
    ^^^^
    ´´´\/```
    Asus Z97 Deluxe MB, Intel i7-4790K @ stock 4GHz, 16GB G.Skill RAM (Trident X 2x8 F3-2400), Asus GTX 970 4GB, Noctua NH-U14S cooler. Samsung 850 Evo 1TB SSD, Seasonic P-860xp2 PS, Antec P-280. Saitek Pro Flight stuff, TrackIR v 5, 1 monitor @2560x1440. Win10, FSX Gold, XP-11, some AC.

Page 1 of 2 1 2 LastLast

Similar Threads

  1. saitek x52 not recognized anymore after last win10 update
    By cargomann in forum PC Hardware, Video And Audio Help
    Replies: 7
    Last Post: 12-16-2016, 03:44 AM
  2. Replies: 0
    Last Post: 08-24-2012, 10:46 PM
  3. Saitek Pro Flight Yoke Or Saitek Pro Flight Rudder Pedals? Which One is a Better Buy
    By Hamzathespartan117 in forum PC Hardware, Video And Audio Help
    Replies: 0
    Last Post: 08-12-2012, 08:43 PM
  4. Replies: 3
    Last Post: 12-26-2010, 06:16 PM
  5. Replies: 5
    Last Post: 12-09-2009, 01:20 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •