Jump to content

Acceleration pack, Windows 10 and Directx 9


Recommended Posts

Just putting FSX onto a win10 64bit pc.


The base game installed and fired up fine. I then installed acceleration, and the game would not start as it wanted Directx 9. I have installed runtime libraries from MS to put the dll's on for directx 9 and rebooted, but no joy.


I uninstalled acceleration and the main game works again.


Just downloading the two separate service packs instead, but wondered if any others had same issue or advice? Actually never used FSX, not sure what I would be missing if using service packs instead of acceleration?

Link to comment
Share on other sites

Indeed, but the base game runs fine on win10 on a fresh install. It is after installing Accelerator that it asks for directx9 and refuses to start. Bit odd really.


You can not install dx9 itself on win10, but you can install the developers runtime library which I have done. After that, the dx9 dll's are in syswow64 folder, d3dx9_24 to dsdx9_43.dll.

Link to comment
Share on other sites



I unpacked the SP2 MSI to get the individual files. Copying FSX.exe across into the program folder from SP2 folder, I get the DX9 missing message instantly. Copy the SP1 FSX.exe across and it goes away again.


Seems to be a coding error/change in the SP FSX.exe file that hunts for DX9 but can not find it on win10. The DX9 dll's are in both syswow and system32 folders.


I found the DX9 installer inside the SP2 folder and ran that separately. It seems to install fine, but again I can not run FSX with SP2 installed on win10.


Good old fs2004. So old it works.

Link to comment
Share on other sites

DX9 is on there, by using the installer on the disc, and also the full downloaded runtime libraries (2010), not web installer. All the DX9 dll's are present and correct.


GPU is Nvidia GTX970 with latest driver.


I just contacted Microsoft support. Whilst giving the 'it's not compatible with Windows 10' line, they did not dismiss it out of hand and confirmed they are working on a fix. When it is released, nobody can say.


For now, I am stuck on FSX + SP1, which is jolly frustrating when you see and hear of folk using SP2 on win 10.


Back over to FS9 for now.

Link to comment
Share on other sites

hey So i have been dealing with same issues basically the only way to fix it is that you reinstall the Flight sim fully, a friend and i working on a solution on how to fix this issue once we come up with the solution we will publish it online
Link to comment
Share on other sites

Look forward to your solution Soar.


For info I did try the following.


1. Installing directx9 from installer found on disk (one from ms website refuses to run on win 10 machine) after installation of FSX.


2. Uninstall FSX, install directx9, reboot reinstall fsx. Same prob. FSX +sp1 works, add sp2 and it will not run.


Is it a bit simplistic to say to edit the .exe file not to check for dx9?

Link to comment
Share on other sites

I am a week or two away from going from XP to Win 10 and I wish you would say 'DirectX 9.0c' if that is what it should be and not 'Directx9'. Could be DirectX 9.0c has been 'patched' and might work with Win 10 whereas DirectX9 might not (ever) work with Win 10. Just trying to understand what IS the problem. As has been said others don't have a problem with FSX Accel in Win 10. Why does it (problem) have to be with DirectX?

Chuck B

i7 2600K @ 3.4 Ghz (Turbo-Boost to 3.877 Ghz), Asus P8H67 Pro, Super Talent 8 Gb DDR3/1333 Dual Channel, XFX Radeon R7-360B 2Gb DDR5, Corsair 650 W PSU, Dell 23 in (2048x1152), Windows7 Pro 64 bit, MS Sidewinder Precision 2 Joy, Logitech K-360 wireless KB & Mouse, Targus PAUK10U USB Keypad for Throttle (F1 to F4)/Spoiler/Tailhook/Wing Fold/Pitch Trim/Parking Brake/Snap to 2D Panel/View Change. Installed on 250 Gb (D:). FS9 and FSX Acceleration (locked at 30 FPS).
Link to comment
Share on other sites

Yes, sorry, I mean Directx9.0c all the time.


I followed the following advice from forums and microsoft. Download and install the directx runtime libraries 2010 pack, not the web installer version. This installs missing dll's into a clean win10 system which has Direct 12.


I also tried to download the directx9.0c installer from microsoft. On running the app you get a message that directx9.0c is not designed for win10, and the app won't run.


I then unpacked the SP2 msi and found an installer for directx9.0c. I ran that and it seemed to go through the motions fine.


After doing all this, and rebooting, and checking the dll's are in windows/syswow64 and in system32 folder, I get the message, FSX is not compatible with this directx, and the sim refuses to load.


Note, this is a clean install of win10 on a new machine. I am wondering if the folk who have it working upgraded and existing working system.


The FSX + SP1 runs fine for me. It is just on installing SP2, or Acceleration that it then refuses to open.


I also tried uninstalling FSX, running the directx9.0c installer again, rebooting and reinstalling FSX. Still same issue with SP2.


Am I the only one having an issue with new win10 installation.

Link to comment
Share on other sites

FSX+Acceleration itself installs DirectX9.0c. There is no need to instal it separately.


DirectX9.0 is installed from C:\Microsoft Games\Microsoft Flight Simulator X\Setup\DX - look at all the xxxx-d3dx9-xxxx.cab files there.




You did follow the procedure here - http://fsdeveloper.com/wiki/index.php?title=SDK_Installation_%28FSX%29 especially for FSX Acceleration Pack OR FSX Gold Pack users

Link to comment
Share on other sites

Will check all that out. I have tried installing dx9.0c by letting accelerator do it, and also manually running a dx9.0c installer. It is there, at least I can see the dll files in system folders and FSX+SP1 runs fine as does FS2004. Presumably they would not run without DX9.0c on there.


I think the fsx.exe installed in SP2 hunts for DX9.0c in a different way and can not see it on win10, a clean install of win10 that is.


Has anybody else got this going on a clean install of win 10 on a new hard drive?


As an experiment, I drag the fsx.exe from SP2 onto a working install of FSX+SP1, and immediately get the message that DX is not compatible and the game won't start up. Convinced the problem lies in the fsx.exe file, if anyone knows how to edit them and stop it checking for directx compatibility.

Link to comment
Share on other sites

Windows 10 FSX Issues:


First don't over think it!


Next get all your video drivers in order. If your using Nvidia graphics card then download and run GeForce Experience.


Install all the recommend drivers.


From there do a complete reinstallation of FSX/Acceleration and you should be up and running afterwards.


Windows 10 is not like XP/Vista/7/8, this operating system is controlled by Microsoft, it will report and send back to you any fixes that it needs.

All I know is this:


windows 10  signature.png


Will get you this:


"Remember, All you have to do is ask."


Link to comment
Share on other sites

Nvidia released a new driver today, so updated that.


Uninstalled FSX. Ran the directx runtime library (2010) installer again for good measure. Rebooted.


Installed FSX as administrator. Ran the game, verified it, rebooted.


Installed Accelerator as administrator. Game will not run with the warning message Directx is not compatible. Reinstall Directx 9.0 and try again.


So I did. Same problem. Tried starting in safe mode just to see. Still no joy.

Link to comment
Share on other sites

Well both are in my installation folder for FSX SE. Dont know about Gold version but if the installer is looking in the game folder for a dx9 file and cant find it, it would error out with "no dx9", which is your issue.


So methinks if you add those files and try again it just might work.

Link to comment
Share on other sites

They are in my FS9 installation folder, so I copied those into FSX folder. No luck though. Also put them in system 32 and syswow folders to see if it helped. Still no luck.


BTW it is not the installer that is the issue. It all installs fine it seems. When you click on FSX to start the game though, that is when I get the message.


The game runs fine on FSX+SP1 only. It is just SP2 or adding FSX+Acceleration that is causing me an issue to start the game.

Link to comment
Share on other sites

Solved at last. Here is how.


It is known to install the runtime libraries 2010 pack from microsoft onto win10 to get missing directX dll files. I ran it many times and all the files were always present and correct in my system folders.


Today however I decided to remove all the d3dx9_xx.dll files from syswow64 and system32 folders and run the installer again. This time as they were missing it must of registered something with windows to say they had now been installed. FSX+acceleration start straight off.


Thanks you for your inputs and keeping me thinking. I now look forward to years of solving stutters blurries, low FPS etc, and don;t mention trying to find the SDK without a deluxe disc to hand...

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...