Jump to content

Keyboard view commands

Pineapple Pete

Recommended Posts

Hi Everyone,

I am pretty to new to flight sims so this is my first post here.

My view keys ,. up, down, left, right arrows as well as right click mouse scrolling are none functional in my X-Plane 10. I have 3D forward view box checked in "views" but I cannot get these keys to work or the mouse to work as advertised. The mouse scroll wheel zoom does work.

I have even looked to reset to default but can't find a thing.

Any help would be appreciated.

Also, I noticed one fellow was getting the same "You don't have permission to post" as I even though I have a username and password on the X-Plane.org forum.

I am somewhat irritated with X-Plane as customer service doesn't respond for my requests for help on this issue.

Thanks in advance for any thought.

Nice forum here by the way.

Link to comment
Share on other sites

Hi Pete,


Welcome to the X-Plane forums here at FlightSim.com.


Pete, regarding the view commands, have you selected shift + 9 to enable 3D view? Once in this mode you should be able to pan around the cockpit using the arrow keys.


Don't reset anything yet, but if you do...it's by removing all the files in the main X-Plane 'preferences' folder, However, lets do that as a last resort.


Let me know how you get on (I've had my early morning coffee now:D).





Link to comment
Share on other sites

Hi Dom,

Well, I got to looking around a little more in settings and I had TrackIR enabled. When I deselected that, the keys came back to life. Silly me I guess. So, I set a view where I wanted it and hit Ctrl num pad. But that didn't lock in the view. Did I do that right?

Thanks for taking the time to respond to my original question though.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...