Jump to content

d3d9.dll CTD's FSX Boxed Windows 10

Soar 21

Recommended Posts

hey Guys i just got a new PC (Dell XPS 8700 Special Edition) New Pc Specs Intel i7 4790 X4 W/T HT X8 3.6ghz 16gb of 1600mhz ddr3 ram my previous GTX 750 from my other PC it originaly had a OEM GTX 745 4gb DDR3 (Micro) video card HDD 2.5tb 7'200rpm W/T 32gb sdd so it came with windows 10, not to happy about that any way i constantly get D3D9.DLL CTD's i have tried every thing and i am running out of options on what to do at this point reverting to win7 is not an option And i don't like FSX: SE its to noobish and thats not an option as well.
Link to comment
Share on other sites

Hi Soar 21,


I did a quick yahoo search and found this link http://www.avsim.com/topic/242664-d3d9dll-ctd/. Sorry you'll have to copy and paste as I don't know how to make the link active.


But the gist is getting proper drivers for the vid card.

Did you get windows 10 drivers fr the old card?

Hope this helps,



OH look! It automatically made it active.

Link to comment
Share on other sites

this is the error report Log Name: Application

Source: Application Error

Date: 2015-10-20 4:06:31 PM

Event ID: 1000

Task Category: (100)

Level: Error

Keywords: Classic

User: N/A



Faulting application name: fsx.exe, version: 10.0.61637.0, time stamp: 0x46fadb14

Faulting module name: d3d9.dll, version: 10.0.10240.16412, time stamp: 0x55b99496

Exception code: 0xc000041d

Fault offset: 0x000519cf

Faulting process id: 0x1f30

Faulting application start time: 0x01d10b713a6a1511

Faulting application path: C:\FSX\fsx.exe

Faulting module path: C:\WINDOWS\SYSTEM32\d3d9.dll

Report Id: 6c9a3f57-cb87-457b-ba3d-38b221b4677c

Faulting package full name:

Faulting package-relative application ID:

Event Xml:





















Link to comment
Share on other sites

Minor difference, the matter is not if you use enb, but if you ever installed it. Because this happens if it is not removed correctly.


Can also be related to sweetFX


Try typing d3d9.dll in the search box. Many threads come up.

Link to comment
Share on other sites

You seem to be rooting around in the system32 folder already.

I wouldn't do that myself, I managed to stay out of it so far.

But since you have less reservations:


From your error report:

Faulting module name: d3d9.dll, version: 10.0.10240.16412, time stamp: 0x55b99496


Have you right clicked the file in sytem32 and had a look at the "Details" tab?

Does that file have that same version number?


(I saw in threads references to fsx-se version numbers. Those started with 10.

But Win10 files may start with 10 too I guess.

---Would be interesting if the file in system32 has that exact number, because that would be a strong indication (though still no 100% certain) that that file is causing the error.

---Why not 100%? Because a file in fsx-se could have the same number.... Difficult.)



Deleting or disabling a file in system32 is a bad idea. A very bad idea.


Something I would do: run "sfc /scannow" from admin command prompt. You never know...

--It checks system files for errors and fixes the ones it finds.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...