Jump to content

NO POWER! (Or other stuff, apparently)

Recommended Posts

Away for a month.  Came back and did the update.  Problem:  I'm grounded!  I tried to take off in a couple of different aircraft, but the engine revs up and then dies, long before rotation speed.  Checked my joystick settings, and throttle is completely responsive to the slider.  (No, reverse slider is not enabled.)  

Then I tried the keyboard.  F3 had ZERO effect.  

Then I tried to retract the flaps with the assigned joystick buttons.  Nothing doing.  Tried F5, which should retract them -- no effect whatsoever.

I've been with FS for 30 years, never had one this stumping.  Do I have to reinstall?


Please help!  I need to get to the Maldives, where I am headed IRL soon. 

Link to comment
Share on other sites

I have had that happen, I shut MSFS down rebooted windows and tried again, I presume it clears some caches and then it worked OK. Just FYI.

Windows 11 MB MSI X-570 -A Pro, CPU--AMD Ryzen 5-5600 3.7 GHz, 6 core, 16G Ram, DDR 3600 MHz AMD Radeon 6800 Graphics card.

Honeycomb Alpha and Bravo, Saitek Autopilot and Switch panel, Echo (Arduino build) autopilot and controller, Saitek Rudder pedals. 3 Monitors.

Oculus Rift 2 Virtual Reality headset.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...