Jump to content

Thrustmaster HOTAS Warthog - Throttle Issues

Recommended Posts

It's been a long time since I've been on the forums here. And a long time since I've spent any time on my flight sims. But I've recently taken up the hobby/gaming again and this is how I discovered the issue.


I've built a new PC with all new hardware and a clean install of Win 10. With that I installed MS Flight Sim 2020, DCS, and FSX. All was well... or so I thought.


Then I plugged in my HOTAS Warthog and tried to go "flying." The throttle was all messed up so I started troubleshooting.


What it boils down to is that the throttle and slider are reversed. Full throttle reports 0 and Idle reports 65538. I've used the Windows Joystick (Game Controller) Calibration Tool and verified this. I then tried the HOTAS on two other Windows 10 machines; a Lenovo Yoga laptop and a Microsoft Surface Pro. All these have the latest Windows 10 updates and the throttle is reversed on all three machines.


For further troubleshooting I then plugged the HOTAS Warthog into my "Retro" Windows XP machine and the calibration is perfect on this PC. I normally use the T.16000M FCS HOTAS on this Windows XP PC saving the Warthog for the best PC I have.


But its useless like this.


I reached out to Thrustmaster Technical Support and got just a canned response telling me to calibrate them.


I've used the HOTAS Warthog on Windows 10 before without any issues so I'm suspecting this is a conflict created from some update.


I've searched for hours online for a resolution. I'm not having any luck.


I'm not an engineer but I am technically savvy enough to know how to do basic troubleshooting and I'm confident that the issue is with Windows 10. But I don't seem to see others experiencing this from what I can find in my research.


So I'm reaching out to the experts. Any suggestions? Any ideas for reversing the root cause?


I thank you in advance for any help you can offer.

Link to comment
Share on other sites

I see a lot of onlookers but no responses. I hope someone has some ideas.


Today I did some further troubleshooting.


I pulled down an older PC that's also running Windows 10, but hasn't been used, NOR updated in at least six months. So its quite a bit out of date.


When I plugged in the HOTAS Warthog it was also showing the throttle and slider as inversed.


I then pulled out a brand new, never used, never even opened, Thrustmaster T.Flight HOTAS One - Ace Combat 7 Skies Unknown Edition and plugged it in. It TOO is showing the throttle Axis as inverse.


Both of these HOTAS's Throttles are inversed on Windows 10. However, both perform perfectly on Windows XP.


I'm really at a loss and would love some help. Thanks again in advance.

Link to comment
Share on other sites

Maybe I don't fully understand the problem, but over many years of flight simming I have from time to time run into the same problem with some programs and flight sticks. In each case it was solved by simply reversing the throttle action in the controls adjustments.
Link to comment
Share on other sites

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...