Jump to content

Download STUCK, keeps trying to download same file over and over

Recommended Posts


I downloaded FS2020 and it worked fine, so my PC must be capable.

I then tried to add an airport (High Wycombe), the download crashed (not sure if that is the right terminiology)

I am not sure of the exact chain of events from there, but ultimately FS2020 wouldnt work.

I have literally purchased a new PC to play this game, so I bit the bullet and decided that nothing ventured nothing gained, I reset the PC and completely re-installed windows again with a brand new fresh copy of windows, thinking that would HAVE to sort it.

But no , it hangs (again not sure if right terminology) when it gets to a specific file (see attached) and then keeps trying to download it endlessly.

STEAM have provided me me with basic support but have now said it is a launch iss ue ...but it isnt it is a download issue.


I am still using the same login with STEAM as I did when I first downloaded the game and when it did actually work for (less than a week)

Could there be some kind of 'LINK' between STEAM internal settings and the above issue?

I have followed STEAM's support sussgestions but nothing makes a difference.


I would really appreciate some help / feedback / support in getting this game to download again

MS download error.png

STEAM Support.pdf

Link to comment
Share on other sites

Hi, sorry to hear you’re having problems. I bought MSFS from the MS Store myself so not sure I can help, but you might be able to repair the sim? I’m assuming it’s the same as the store version in this way.

Go into app settings & try “repair” - failing that, maybe “reset” will work.

Of course neither might help but it’s probably worth a try,




Intel I9-13900K - Gigabyte Z790 Aorus Elite AX - 64Gb DDR5 5600Mhz - Asus RTX4090 ROG STRIX 24GB

3x 43” Panasonic 4k TVs - Corsair RMx 1200W PSU - 2 x 2TB M.2,  2 x 4TB SATA III and 1 x 4TB M.2 SSDs.

Pico 4  VR Headset - Honeycomb Alpha Yoke - Honeycomb Bravo Throttle Unit

Thrustmaster TPR Rudder Pedals - Saitek Throttles

Link to comment
Share on other sites

Crazy thought just hit me, could it be your anti-virus? Is Steam in the excluded list of programs? If it is sticking on ONE file, then it could be a program preventing it? Have you alt/tabbed though the list of open programs/windows? You might have one hidden that is stopping the process.


Just some random thoughts

Windows 10 Pro, 32 gigs DDR4 RAM, Nvidia GForce RTX 3070, Intel I7 10700 running at 3.8, with Noctua NH-L9x65, Premium Low-Profile CPU Cooler-HP Reverb G2 for Virtual Reality
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...