Jump to content

RNAV Glide scope inop after update 9/29/2020

Recommended Posts

I have tried several Rnav approaches from multiple airports and the Rnav never grabs the glide scope. This started after the update today. I have tried closing the program, rebooting the computer and it still fails.


Anyone else experiencing this and have you found a fix.



Link to comment
Share on other sites

I suspect they turned off RNAV temporarily so that they could work on the FMS??

BTW isn't that slope instead of scope?

I7-9700K, RTX-2070, Asus Strix Z-390-H MB, 32gb G Skill 3000 CL15, Corsair Obsidian 750D case, WD Black 1tb M.2, Crucial CT500MX SSD, Seasonic Prime 750W Titanium PSU
Link to comment
Share on other sites

scope/slope..ok..got it...

So going into the sim, it would seem none of the approach flight plans work. I tried both ILS and Rnav.

Once I load an approach, the flight path on the center screen disappears and the plane flies directly to the destination airport. No waypoint markers indicated. No activation of glide slope...

Also it would seem that the ATC thinks the aircraft is somewhere else. It cleared me for a landing at an airport that I was 20nm away from. I am flying the TBM 930. Is anyone else experiencing this problem?

Link to comment
Share on other sites

  • 3 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...