Jump to content

GoFlight and Windows 10


Recommended Posts

Got it working, mostly stable now! Not sure if people are still having problems, but thought I'd share this since some might have given up. My hardware, gf166 (2), rp46 and 48. I need to say this hardware has always been finicky, and they will be times when a display freezes, happened a few times even in win7.


The backstory, I just upgraded my gaming machine from win 7 to 10. I was about to give up, even considered buying a Saitek radio module, but I prefer Goflights' amber colored displays, easier on the eyes.


Some things need consideration that no one might have mentioned before:


1) if possible, use a USB 1 extension hub plugged into USB 2 port. (Make sure you NEVER plug this hub into a USB 3 port, it damaged one of my hubs, (it was working perfectly in win 7) and didn't even know it caused me plenty of confusion! These older hubs are pretty rare, if not even available. And they can be damaged when plugged into usb3. I checked the hubs' power supply with volt meter, still good, but the USB hub itself cannot be powered anymore, and without power, the connection does not always work consistently with different low-powered USB devices. This problem took me down the wrong track, and I am certain others have suffered from it.


2) after all GF modules are confirmed up and running, (after lots of trial and error), make sure to turn off power to USB hub after computer is shutdown. Better yet, leave all extension hubs on power strip for easy access.


3) when you are ready to turn on your machine, turn on your USB hubs first, then power up on your machine.


4) do not run GFconfig while FSX is running. (It only needs GFdev.exe, which loads automatically with FSX). GFconfig should run outside of FSX for configuration only. (Related: GFdev.exe cannot be running if assigning keystrokes to rp48).


5) if you exit FSX, leave your machine turned on, and decide to restart FSX, then you will need to kill and restart GFdev.exe while in-game. (You will find no buttons are responsive). Solution is to switch FSX to windowed mode, then task manager to kill GFdev.exe. Helpful to have a shortcut to GFDev.exe for restarts. Then task back into FSX, the buttons should be responsive.


The best option is to turn off your machine and your USB ports until next gaming session. There is still a chance one of the high powered LED displays (gf46/166) will be lost if you have too many sessions with FSX without a re-boot. In that case, only a re-boot works.


I have repeated this these many times, and believe my goflight hardware setup in win 10 is as stable as it can be. Hope his helps someone

Edited by macflyer
Link to comment
Share on other sites

  • 2 weeks later...

Wanted to add a bit more, I cannot Edit previous post:


1) Most of you have figured out GFdev.exe = GFdevFSX.exe, it stays in memory.

2) Another way to recover any lost modules is to exit FSX, re-insert USB plug, then run GFConfig to confirm all modules light up. Exit GFConfig (modules will go 'dark') then re-start FSX. You will need to repeat step 5 while in FSX. (It helps if the powered USB hub is within your reach).


I realize all this might sound convoluted, but you get used to it. And there might be more efficient steps to take, in which case I would like to hear about them. My way is not the only way!


All of my FSX sessions has been successful thus far, though this information should provide some clues to the developers of GoFlight as to what is needed to make a more robust Windows 10 driver, at least I hope they release something in the near future to make it easier for us.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...