Jump to content

My PC's DVD drive just chatters away trying to install FSX in Windows 10


Recommended Posts

I know my set of FSX Gold disks are perfect, clean and OK for Windows10.


They also install without any issue on other laptops I’ve tried, including half a dozen on the shelf at PC World etc! Also, a/v (Panda and Malwarebytes) was disengaged during all attempted installs.


It's just my PC - Disk 1 goes in and then chatters away for at least 90+ minutes before reading enough to start installation. Same with Disk 2 and likewise the third, Acceleration disk.


I've tried changing physical drive hardware, updated/reinstalled DVD drivers, also tried plug-in drives, plus increased the power supply from 600W to 750W.


Sometimes, the change works at the first attempt … but then always reverts back to the same old problem.


If I wait long enough (90+ mins) the chatter usually stops (Disk1, but not on inserting Disk 2 or the Acceleration disk). I can start an installation from here, but end up with the error code: 1-80004005 which I guess is an activation problem with the Acceleration install.


I’ll have to see if I can resolve this (as described in thread Flight sim boots me off – 04/26/2019).


Is it some conflict arising between drivers loaded somewhere in my PC and the write-protect of the install disks?


If so, why doesn’t the same issue happen with other programs? Am I really the only one to have ever experienced this problem?


It’s soooo very, very frustrating, not least getting brief glimpses of what I should be able to run.


Any ideas what I can do to solve this would be really welcome please!!


Bob C

Link to comment
Share on other sites

You might find that when you browse to the install exe (as opposed to using 'Auto Run' to begin intall) that if you DO NOT do 'Right Click' and 'Run As Adminstrator' that the process will run 'full speed' with no clatter of disc, etc. And when you get it installed and have FSX icon on desktop that you also NOT DO 'Right Click' and 'Run As Adminstrator' will suffice. FSX lets Win 10 do what IT (Win 10) wants to do when you 'Run As Adminstrator' (ie: give Win 10 permission to run files thru what ever 'filter' it wants to use) thus messing up your attempt to install ANYTHING. Especially FSX. Win 10 hates FSX. My 2 cents.

Chuck B


Edit: BUT, if you are going to install to 'Program Files' then all bets are off as that alone is totally wrong.

Edited by napamule2
i7 2600K @ 3.4 Ghz (Turbo-Boost to 3.877 Ghz), Asus P8H67 Pro, Super Talent 8 Gb DDR3/1333 Dual Channel, XFX Radeon R7-360B 2Gb DDR5, Corsair 650 W PSU, Dell 23 in (2048x1152), Windows7 Pro 64 bit, MS Sidewinder Precision 2 Joy, Logitech K-360 wireless KB & Mouse, Targus PAUK10U USB Keypad for Throttle (F1 to F4)/Spoiler/Tailhook/Wing Fold/Pitch Trim/Parking Brake/Snap to 2D Panel/View Change. Installed on 250 Gb (D:). FS9 and FSX Acceleration (locked at 30 FPS).
Link to comment
Share on other sites

  • 1 month later...

• regedit

• as administator

• Hkey_Local_machine

• system

• current control set

• control

• class

• search for string:


and double click.

• You see on the right: upper filters. Double click on that.

• on the left you see 'value data'. In that you must write or change: PartMgr P and M CAPITAL.


Close regedit and restart FSX and you can activate Acceleration.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...