Jump to content

how to fix install issue with fsx sp2

Recommended Posts

i tried to install my pmdg 737 and it said i was on an outdated version of fsx and that i needed to install fsx sp2 i was confused as i had installed it a few weeks prior. I uninstalled it and upon reinstalling i noticed that it cut in the middle of the installation were it was updating direct x10 and then it said it was finished. I tried installing my pmdg again it said it was outdated. Ive tried uninstalling and reinstalling multiple times and the istallation still Cuts in the same plays and my pmdg install still says my fsx is outdated. Has anyone had the same issue and know how to solve the problem?
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...