Jump to content

FSX and ADE issues


Recommended Posts

Hi guys,

New here. Lots of great stuff available. I'm recently getting back into flight sim as I lost my medical just about as I was getting ready to complete training. With the knowledge provided here and a few other places, I am hoping to make my Sim experience as realistic as possible. I've painted a C-152 to resemble the one I was training in and I've added some AI traffic to my local airports. KPIA, KBMI and KSPI. I found there are limitations to using the stock airports with AI. So I got the latest version (1.65) of ADE. And then I ran into trouble.

1) Updated and compiled my version of KPIA.

2) Got some compiler errors and fixed those.

3) Tried to compile again and got a message telling me that my bgl compiler didn't work and that I needed to upgrade to SP1a.

4) Upgraded to SP1a and got the same error. So I checked around and found an SP2 update.

5) Tried to install it and was told I needed SP1a first.



I am at a loss now. I have FSX Deluxe and a Windows 10 machine. Can anyone give me some guidance?




Link to comment
Share on other sites

As it appears that SP1a failed to install correctly, possibly due to a permission issue, I would uninstall it, reboot the PC using the RESTART option and then attempt to reinstall SP1a again. However this time instead of simply running the installer RIGHT click on the .exe file and select Run As Administrator from the resulting menu - this will ensure that program is installed with no permission issues. Once installed try ADE before attempting to install SP2 using the same process.


WRT to the version number of ADE - the latest version is 1.75 and is available from HERE - its the top link in the listing. Note that the manual for this version is not included in the main download but is available via the link provided in the 3rd entry of the listing.


Another is might be that you are also missing another required OS based component - Msxml04. This does not ship with Win 10 and needs to downloaded and installed separately - it can be found HERE. Do not run the installer directly from the download link. Save the file to a temp location and install it as per SP1a instruction given above.




Link to comment
Share on other sites

What it probably said is that you need the: Fsx-SDK sp1 and 2. The Software Development Kit Updates.


The SDK needs updating, because your fsx install is also fsx sp1 and 2.


The SDK contains the required compilers needed to use ADE(X). (and contains many more tools as well.).


Google: Fsx-sdk

and find the Wiki guide that explains the SDK install.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...