Jump to content

Usage of NavDataPro from aerosoft


Recommended Posts

Hello guys,

I post this question because I am unable to use the NavDataPro base from Aerosoft.

I have subscripted for the up to date AIRAC from Aerosoft and downloaded the software tool and the data with the registration key given with the invoice.

Installation of tool has been successful but when I try to install the data base in my FS2004, installation fails.

The support team of Aerosoft which I have contacted indicates that something is wrong in my FS2004 installation, particularly the modification of folder authorizations. I have tested various modifications of the attributes of my folders and modifications of my antivirus protection.

Nothing operates.

I have tried, following their advise, to load the base in a dummy folder called MyTempFS which I have installed on the C disk in which I have introduced a folder called FeelThere to test the loading of base for WILCO / Airbus

I am never able to install the airac. The folder aerosoft installed by the NavDataPro application contains a folder called NavDataProCycle containing a compressed FeelThere folder. This folder cannot be unzipped because it request a password that I do not have. The aerosoft support team to which I have made the remark, answers that nothing manual is necessary, the NavDataPro application must do everything automatically.

But in my case, it does'not work even if I follow step by step the instructions of the manual.

Does someone experience such a blocage?

Any help would be useful for me because today I have spent money for the subscription but cannot use the data

Link to comment
Share on other sites

... from Aerosoft.


can't help you with Aerosoft except to state -



  • if they don't provide you a solution, and you purchase is no, ask for a refund for non-function of product. if that doesn't get them to assist contact your credit card provider and cancel payment.
  • i use NAVIGRAPH with no problem for 9+ years. i've found them to have great customer service - had an issue with their tablet software last week which was solved in less than 24 hours.



Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...