Jump to content

Default city/airport buildings suddenly disappeared?

Jack Keenan

Recommended Posts

HELP! Suddenly default city/airport buildings have disappeared (e.g. KJFK, KEWR, KSEA, KSFO). Disappearance occurred just after recent Windows 10 update, not sure if it's related? No recent add on scenery added, actually no recent new additions...just poof, gone. I've been running for over a year with no such difficulty.


Any way to recover short of uninstall/reinstall?



Thanks in advance.


Jack Keenan

Link to comment
Share on other sites

Hi Jack,

this is strange, I run W10 and the last update did not affect my FS. I would probably check Settings - Display - Scenery sliders. In particular Scenery Complexity and Autogen Complexity at least to be Very Dense. Also Global Scenery Quality is best set as Custom. In either case play with the sliders there to see if the buildings come back.

Another way is to open affected airport in ADE and see how I looks there. The default building should show when you open the default airport. If not, something is wrong.

Good Luck


Edited by beroun

Peter Bendl

ex. British Airways

Link to comment
Share on other sites

Before you do a re-install,..

Copy the whole sim folder from C:\Program Files & paste it directly into C:\

Delete the existing desktop shortcut

Then, open the newly copied folder, right-click the FS9.exe & click 'Properties'

Select 'Compatibility Mode' & select XP

Select 'Run as Administrator' then OK

Right-Click the FS9.exe again & 'Send to Desktop'


Try running it now. - You might have to reactivate your scenery('s) again.





Cape Town, South Africa

Link to comment
Share on other sites


I did all as you suggested. FS ran fine, flew a saved flight with no issues, scenery library appeared normal, but still no buildings (KJFK or NYC, assume other airports and cities also), and still clicking on settings>display closes FS immediately. I appreciate your input, and any further thoughts would be welcome.


Thanks again,



Link to comment
Share on other sites

Robin, Just fyi, I did a system reset back to just before the most recent Windows update, and my problem was solved. In fact, I've had two previous problems which occurred just after previous windows updates, but both of those resulted in square black "place markers" instead of trees. Thought I would pass on the solution, I'm convinced that the windows updates occasionally cause similar problems.


Thanks zswobbie1

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...