Jump to content

Everything works, except everything crashes


Recommended Posts

Hello people,


I am finally looking for advice on this forum, because this is the first time ever, that I couldn't find out what is causing the error.


So I have P3D v3.4 running with several addons, payware and freeware ones. I won't list them to you, because all of them work fine. It's P3D that a few weeks ago decided to give me totally random crashes. I didn't change anything. Neither on the addons, nor my hardware. I can't exclude the possibility, that some addon automatically downloaded an update or something, but I think, I would have noticed that.


So here's what happens since that random moment:

I load P3D, I get the Scenario Setup. I can set up aircraft and position, all of them show up. P3D starts to load everything in, it doesn't take longer or shorter than usual. And then: it's 50/50: sometimes it's working out fine, sometimes it's crashing right there.


So after being unable to figure out what the problem is, I uninstalled P3D and all of the addons. Got rid of any traces in %APPDATA%, %PROGRAMDATA%, even searched the registry and let a cleaning tool remove all the leftovers.


Reinstalled P3D again, added some scenery and addons and boom, here it crashes again, same way that it did before, "eventvwr" gives me this:


Name der fehlerhaften Anwendung: Prepar3D.exe, Version:, Zeitstempel: 0x5851bfd2

Name des fehlerhaften Moduls: unknown, Version:, Zeitstempel: 0x00000000

Ausnahmecode: 0xc000041d

Fehleroffset: 0x1724dd00

ID des fehlerhaften Prozesses: 0x1058

Startzeit der fehlerhaften Anwendung: 0x01d33a4839a48c32

Pfad der fehlerhaften Anwendung: E:\Programme\Prepar3D v3\Prepar3D.exe

Pfad des fehlerhaften Moduls: unknown

Berichtskennung: 563d7985-51ea-4240-8ad0-a6ef1801e72c

Vollständiger Name des fehlerhaften Pakets:

Anwendungs-ID, die relativ zum fehlerhaften Paket ist:



And here is what makes me become desperate: It crashes always after the loading bar reaches 100% - but sometimes, everything just works fine. I just cannot figure out, what causes the crashes!


So I start P3D.

I can spawn a PA28 on a small ORBX VFR Airfield. Works. Exit P3D, restart.

Spawn a DC-10 on the same airfield: Works. Exit P3d, restart.

Spawn a DC-10 on a standard scenery airport: Crash. Restart.

Spawn a PA28 on the same standard scenery airport: Works. Restarting the machine.

Spawn a DC-10 on the same airfield again: Works. Restart.

Spawn an Aerosoft A319 on the same airfield: Crash. Restart.

Spawn a PA28 on the same airfield: Works. Restart.

Spawn a PA28 on the same airfield and switch it to a A319: Works.

Spawn a A319 on the same airfield: Crash. ARGH!


I thought it might be the weather, thought there might be issues with the textures that I installed. So i tried it with different weather settings: the randomness continues. When it decides to properly load up, I can also use FSXWX and inject the weather perfectly fine.


I thought it might be the SimConnect stuff, but then again: When it decides to properly load up, the A319 works just fine.


It's not the scenery, for it is working perfectly and looking gorgeous WHEN it decides to load up properly.


It's not the aircraft, for it is working perfectly and looking gorgeous WHEN it decides to load up properly.


I thought it might be some addons interfering with each other. But it even occurs with only one addon-aircraft installed.


It's not anything. Everything seems to work. I have absolutely no clue. I consider myself to be quite able to figure out and solve problems myself. But this one is the first one that I'm completely overchallenged with.


This is why I came here and tried my best to explain the problem to you in my broken english and desperately hope, that someone professional will take his or her time to read this and probably have any clue about it.


Thank you very much in advance,

greetings from Germany,


Link to comment
Share on other sites

I've been circling the problem for several hours now and can give you some additional information:


Sometimes, the sim loads up and is running for a 2-3 seconds, it actually renders everything - and then crashes. So I figured that the crashes must be caused by something, that is loaded at the very end of the loading sequence or near the beginning of the simulation sequence, if that makes any sense.


If only I could look behind the curtains and see, what the sim tries to do and can't. It's so frustrating.

Link to comment
Share on other sites

I found that just yesterday while randomly clicking through crash threads in the other forum and yes, this is the problem for me. With uninstalling the update and preventing it from installation P3D seems to work just fine. Thank you for your kind help, this thread can be closed here.



Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...