Jump to content

FSX Rotor Animations - Only Works Properly For First Rotor in Multiple Rotor Model


Recommended Posts

I am converting a helicopter model from FS2004 to FSX and P3Dv4. The FS2004 model has messed-up rotors in FSX and does not work at all in P3Dv4. I have three separate rotors on the aircraft I am trying to animate. I am working with the latest version of FSDS. I have made many models, including helicopters, in FS2004, and aircraft models in FSX, and converted one model to P3Dv4, but this is the first time I've done a helicopter in FSX.


The first rotor I animate works perfectly. The next two rotors work except that the three associated animations (rotor_still, rotor_slow, rotor_blurred) remain active the entire time. For example, the rotor_blurred animation is active even when the rotors are stopped, along with the other two animations.


I have been able to improvise something that looks pretty good in FSX, but it looks terrible in P3Dv4, so I would like to try and fix this. I have reordered the rotors and it simply relocates the problem. I have tried many combinations of hierarchies in the model - making the rotors sub-parts of various other parts and of each other. Doesn't work. I have also tried using the prop animations. Someone who programmed FSX decided helicopters don't have props, so the prop animations do nothing.


I have also experimented with editing the modeldef.xml file. I added rotor_blurred1, rotor_blurred2, and so on. That worked great until trying to compile. It failed to compile because I had duplicate guid's. I think if I could duplicate the animations and assign a unique guid, that might solve the problem, but I don't know how to do that.


I have also tried editing only the code in the modeldef.xml file that controls when the animation is on, and assigning the code to the names that FSDS assigns for the duplicate rotors (rotor_slow.1, rotor_slow.2, etc.). It compiled but had no effect.


I've decided it is time to seek help with this puzzle. Many FSX helicopters with multiple rotors exist, so it must have been solved. Any help would be greatly appreciated.


David Allan


Link to comment
Share on other sites

Problem solved, at least for FSX, by editing the modeldef.xml file. Instead of reusing guid's when I created the different animation definitions, I used a random guid generator to assign new ones. That eliminated the duplicates and allowed it to compile. All the rotors now work properly in FSX. I'll reply again if it does not work in P3Dv4.
Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...