Jump to content

Highly frustrating joystick experience

Recommended Posts

Hi, some of you may know I am in the process of building a new system, which may take a month or so. However, this is about the problems I am suddenly encountering with my joystick.



-I have been playing FSX for the last 3 years, and Fs2004 before that. I have always been using a Logitech Attack3 without any issues whatsoever.

-I had Prepar3D version 2.2 installed and joystick worked perfectly.

-Last week I finally installed Prepar3D version 2.4. Right away I noticed the throttle was not working in the joystick, while all other functions were still working.

-The joystick worked still fine in FSX.

-Last night went and bought a new joystick, a Logitech extreme 3d pro. Installed it without the software (none came in box).

It worked fine with Prepar3D after calibration, did test flight, everything ok.

-Today, fired up Prepar3D, and right away noticed a problem with the new joystick related to the rudder, almost had no control over it. I have read that has

to do with the Z rotation.

-I have tried to re calibrate thru Windows, but noticed that the Z calibration does not work.


I have read some posts about it but I am getting more confused by the minute.

Link to comment
Share on other sites

Have you checked to see if the Yaw Damper (if any) is off? I don't know about Prepar3d, but leaving (or turning) the YD on in FS9 virtually eliminates rudder movement, no matter how far one twists...




Had a thought...then there was the smell of something burning, and sparks, and then a big fire, and then the lights went out! I guess I better not do that again!

Sgt, USMC, 10 years proud service, Inactive reserve now :D

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...