Jump to content

Tools not showing in FSX

Recommended Posts

Hi looking for some help please.

My hard drive died on me lately and I lost all my games.

Lesson learned so I got 2 hard drives now.

My C drive is now for OS only and the F drive will be for games!

I'm having trouble installing SDK into FSX as it's not showing up.

If I can just explain what is the current situation is;

FSX is a Deluxe Edition

FSX is installed in F drive, no problems.

FSUIPS 4.9 is installed in F drive also, no problems.

I installed SDK in F drive not showing up!!

I am aware of the Disable/False/Disable issue which I have changed.

Also I ran ConfigSDK for the regitry.

I am I right in saying that the .dll file is in %appdata%/microsoft/fsx/.dll and that operates

the Tools in FSX?

Or is it somewhere else??

Also I'm wondering is SDK having a problem with the root directery?

The F drive is F:/Games/Microsoft/FSX/SDK/SDK/Enviroment Kit/Traffic ToolboxSDK

I tried to install SDK in the C drive but the ConfigSDK wouldn't work!!

I've run of ideas or I'm missing something!!

Any help would be great, thanks Don.

Link to comment
Share on other sites

  • 4 weeks later...

Hello Cpt.

I just installed FSX Deluxe with the SDK last night into a separate User account so that it wouldn't conflict with the FSX-SE that I already had installed. I got everything working and made my first BGL scenery file for both programs, so maybe I can help. I used the default C:\ locations, but I think the problem you're having is with coordinating the service packs so that the file versions match when loading the DLLs. So I'll tell you what I did to get my FSX SDK up and running.


Install FSX Deluxe from the DVD. Try to run it. Mine crashed constantly on my Windows 8.0 system. Search for FSX Service Pack 1 and install it. The link is below:




Note that this has NOTHING to do with the SDK service packs. That service pack just got my FSX game to run on 8.0 without crashing.


Now install the SDK that came on the DVD. Enable the SDK files.

Go to C:\Users\Username\AppData\Roaming\Microsoft\FSX and change the dll.xml file to show the correct file path to the .dll and change True to False. Ex:

Object Placement Tool



C:\Program Files (x86)\Microsoft Games\Microsoft Flight Simulator X SDK\SDK\Mission Creation Kit\Object_Placement.dll


Now go to

C:\Program Files (x86)\Microsoft Games\Microsoft Flight Simulator X SDK\SDK\Core Utilities Kit\SimConnect SDK\config

and copy these two files: SimConnect.cfg and SimConnect.ini. They're going to tell you if the three SDK dll's are loading correctly when you start FSX. Paste those two SimConnect files to C:\Users\Username\Documents\Flight Simulator X Files.


Try to start up FSX normally.


The little SimConnect black box will appear and tell you that the 3 SDK dlls didn't load, but FSX should still be working fine otherwise. This is due to a mismatch in file name versions because you used Service Pack 1 to get the FSX game to run. Now you apply the SDK service patch 1a that will update both the SDK and FSX file versions so that they'll both match. Note that this is going to completely rewrite all of the original SDK files.




Try to start FSX again. For me, this was all I needed to do to see the Tools menu in flight, use Object Creator Tool and make my first XML scenery file.


I further upgraded to FSX Deluxe SP2 for the add-on compatibility with my FSX-SE/Acceleration, which is the FSX version that I fly with most.




But that FSX Deluxe SP2 upgrade changed the file version numbers again and my SDK dlls wouldn't load, which I could easily see from the SimConnect black box. So I had to install the FSX SDK service pack 2 to fix that mismatched file version problem.




Now I'm up and running again and both of my FSX versions and the SDK work just like they're supposed to. I hope this helped :)

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...