Results 1 to 10 of 10

Thread: P3D 3.1 Crash to Desktop - Sim1.dll c0000005

  1. #1

    Default P3D 3.1 Crash to Desktop - Sim1.dll c0000005

    All,

    I posted this question in the P3D, and AVSIM CTD forums with no response.. I have uninstalled reinstalled by add-on and continue to get the error. The full error message is in the OP. All I've been able to find out through research is that the sim1.dll was an issue in FSX a long time ago and that the c0000005 error means that something is trying to access memory that is not supposed to. Could someone at least get me on the right track? It's frustrating that no one has responded over in the P3D forum. Please Help.

    OP:
    http://www.prepar3d.com/forum/viewto...=6312&t=116718

    Win 10-64, i7 8700K OC to 5.1GHz
    GTX Titan XP

  2. #2
    Join Date
    Sep 2012
    Location
    Germany
    Posts
    1,679

    Default

    A few things to try:

    - reinstall the VC 2010, 2012, 2013 redist runtime libraries (both 32 and 64 bit). You can download them directly from Microsoft
    - reduce your OC.
    - thoroughly check/test your RAM for errors.

  3. #3

    Default

    Nope, Dont do that. Not yet.

    Remove the PMDG aircraft from the sim. Does that fix it?

  4. #4

    Default

    Thanks guys. I'm going to reinstall and test one add-on at a time with default settings; PMDG will be first.

    Win 10-64, i7 8700K OC to 5.1GHz
    GTX Titan XP

  5. #5

    Default

    Mall,

    It's not PMDG. I Just did a clean install of P3D and got no crashes with default aircraft or the PMDG T7. I'm also doubting that it's a hardware issue since FSX runs fine, and P3D V2 ran fine a few days ago. The next suspect is FSUIPC.

    I will keep you in the loop as tests continue.

    Thanks

    Win 10-64, i7 8700K OC to 5.1GHz
    GTX Titan XP

  6. #6

    Default

    To my certain knowledge FSUIPC has never been the cause of a Sim1.dll error.

    Make sure you have the latest version

  7. #7

    Default

    Update: I did a lot of testing this week and have it narrowed down to an issue with NVIDIA Inspector or a Gold Star Texture repaint for the PMDG 777.

    After I got all the add-ons put in, I set up NVIDIA inspector, downloaded my AA livery for the PMDG 772, and updated my P3D sliders. It was at that point that I started to get crashes. I returned everything back to default and tried a flight with the PMDG 772 with the Gold Star Texture livery and got another crash.

    I then deleted the Gold Star Textures paint job, downloaded the P3D AA fictional livery through the PMDG Ops center. Then I updated my P3D sliders to pretty high settings without NVIDIA inspector and the crashes stopped.

    Gold Star 777 livery - I don't know why this would crash P3D. I know PMDG made some tweaks to the airplane to improve memory management and maybe the older Gold Star paint job doesn't jive with it. I'm going to reinstall it and see if it will go without NVIDIA inspector set

    NVIDIA Inspector - This is where I really think my issue is. I don't know why, but maybe it isn't jiving with some internal P3D settings. With the graphics options in P3D being what they are, I think my sim looks great without NVIDIA inspector, so if I can get the sim to not crash with the Gold Star texture pack in. I'm going to stop and no longer use NVIDIA inspector.

    Win 10-64, i7 8700K OC to 5.1GHz
    GTX Titan XP

  8. #8
    Join Date
    Mar 2005
    Location
    Burbank CA USA
    Posts
    2,320

    Default

    I'd be more inclined to suspect the driver itself, not NVI. Try rolling back the driver. Be sure to RESET the NVI P3D profile to default and make no changes.

    Vic
    P3D Rig
    I7 7700K @ 5.0ghz Asus Maximus X270 16G G.Skill 3600 15-15-15-18 2T EVGAGTX1080ti Corsair 1000W PSU 1TB Samsung SSD for P3D - 2 - 256G OCZ Vector SSD - HAF X - Corsiar H100i V2 Liquid Cooler W10 64 Pro.

  9. #9

    Default

    Thx Vic,

    The first time I had the error was on an old driver; I updated to the latest and still got them. Is there a specific driver people are having success with? I reloaded the Goldstar texture pack and haven't had the same crash yet. In fact last night I was able to complete a full flight in PMDG without the sim1.dll crash. Of course tonight I got a ntdll.dll CTD which I'm tracking as an issue with ASN. I've had the ntdll.dll error a few times usually when closing P3d.

    Is it me, or are there way to many CTDs being reported with version 3? There are CTDs reported all over the P3D forum, so my initial thought is that LM and 3rd party developers still have some kinks to work out.

    Thanks again,

    Dave

    Win 10-64, i7 8700K OC to 5.1GHz
    GTX Titan XP

  10. #10
    Join Date
    Sep 2012
    Location
    Germany
    Posts
    1,679

    Default

    Quote Originally Posted by dfreemanfso View Post
    Is it me,
    It is not just you. I am getting these as well, sometimes I get the sim1.dll, sometimes the sim just closes silently without any event log. Somehow it seems to have gotten worse, today I wasn't able to fly more than 10 minutes in every session that I tried.

    Addons installed today were the RealAir Lancair, the MilViz Phantom and the JF F-111.

    One similarity that I see is that we both have a 780 series GPU (780ti on my part). Maybe just maybe P3D does not like Kepler chipsets. I think I can rule out NVI, because I didn't change anything there from when P3D 3.1 worked almost every time, to no longer working at all.

    But I am no nearer to a cause or explanation than you are, sorry.

    Edit: what sound device are you using? IIRC there was an issue with Creative sound drivers in 2.x and it seems to be there still - I can see event logs from the licensing service. Disabling that service seems to have improved matters.

    2nd Edit: That seems to have done the trick. Check your event logs if you see a notification about a service or program starting or stopping right when your sim crashes. In my case it was the "Creative ... Licensing Service"
    Last edited by evm; 01-25-2016 at 04:12 AM.

Similar Threads

  1. sim1.dll problem
    By clivepugh in forum FS2002
    Replies: 3
    Last Post: 02-08-2005, 09:01 AM
  2. Replies: 0
    Last Post: 01-14-2005, 01:27 PM
  3. sim1.dll and DX9.0b
    By Shep in forum FS2002
    Replies: 5
    Last Post: 07-29-2003, 02:06 PM
  4. sim1.dll error
    By romeotango in forum FS2002
    Replies: 0
    Last Post: 08-26-2002, 09:33 PM
  5. HELP - I NEED TO RESTORE MY SIM1.DLL FILE
    By BILLYWEBB in forum FS2002
    Replies: 5
    Last Post: 06-20-2002, 02:25 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •