Results 1 to 7 of 7

Thread: MSFS Icon only opening the Microsoft Store.

  1. #1
    Join Date
    Feb 2013
    Location
    Charlottetown PEI
    Posts
    77

    Default MSFS Icon only opening the Microsoft Store.

    Good day good people,

    When I double click the MSFS Icon on the desktop, it will only open the Microsoft Store Showing the Gaming Services App install option.

    I have installed it but the Icon will only open the Store again.

    Strange. It was working yesterday.

    Anyone else noticed this or is it just something on my system?

    Thanks for any suggestions.

    Hal
    Alienware Aurora R8, I7-9700K, 32g memory, 1t NVMe boot drive, 2 - 1t SSD for MSFS, 1t SAT drive for storage, RTX 2070 Super 8g,

  2. #2
    Join Date
    Feb 2013
    Location
    Charlottetown PEI
    Posts
    77

    Default

    Here is a shot of the screen when I try to launch the Sim.

    Click image for larger version. 

Name:	MSStore.JPG 
Views:	17 
Size:	97.8 KB 
ID:	225623

    As you can see, it says installed on the left, but the icon will not open the Sim. I cannot open the sim from the search bar either. I can find Microsoft Flight Simulator App, but it just opens the store also.

    Hal
    Alienware Aurora R8, I7-9700K, 32g memory, 1t NVMe boot drive, 2 - 1t SSD for MSFS, 1t SAT drive for storage, RTX 2070 Super 8g,

  3. #3
    Join Date
    Sep 2020
    Location
    Aurora, CO
    Posts
    30

    Default Gaming Services

    Not sure if it is related, but I've had issues with Gaming Services. I found that, by running Windows Task Manager, there are two instances of Gaming Services running. I end task on one of them, and that rerurns MSFS functionality...

  4. #4
    Join Date
    Feb 2013
    Location
    Charlottetown PEI
    Posts
    77

    Default Solved

    Just an update here.

    I reported this to Zendesk and just had a reply that has got me up and running again. Reply time about 1/2 hour.

    I will post here what I had to do to clear things up;

    "First, please do the following in this order:
    1. Click on Start (the Windows icon in the bottom left corner of your screen)
    2. Select Settings
    3. Go to Update & Security
    4. Stay on Windows Update
    5. Click the Check for Updates button.
    6. Wait until the verification is done.
    7. In the Windows search bar type "Store" and open the Microsoft Store app installed on your computer
    8. In the top right-hand side corner of the Microsoft Store app, click on the Arrow icon or the three-dots menu
    9. Select Downloads and updates.
    10 Click Get updates and Update all
    11. Reboot the computer

    If the problem persists after that you'll need to make sure that Gaming Services is installed and running. To do so, follow the instructions below in that order.

    Step1. Reset Gaming Services
    1. Close Microsoft Flight Simulator
    2. From your computer Start menu, navigate to Settings > Apps
    3. Type "Gaming" or "Services" in the search bar
    4. Select Gaming Services
    5. Click on Advanced options
    6. Click Reset
    7. Reboot the system
    8. Launch Microsoft Flight Simulator"


    The first part on the above did not help in my case, but the second part did the trick.

    Thanks to all who looked to see if they could be of assistance.

    Hal
    Alienware Aurora R8, I7-9700K, 32g memory, 1t NVMe boot drive, 2 - 1t SSD for MSFS, 1t SAT drive for storage, RTX 2070 Super 8g,

  5. #5
    Join Date
    Mar 2005
    Location
    Getting warmer now
    Posts
    8,524

    Default

    Glad to see you're up and running again. And thank you for following up with the solution.

  6. #6
    Join Date
    Feb 2013
    Location
    Charlottetown PEI
    Posts
    77

    Default

    Your are welcome Loki.

    I like to post any problems and the solution in case someone else has the issue.

    I was very surprised by how fast the support team got back to me. I emailed them back that the problem was solved and had another email within 5 minutes.

    Hal
    Alienware Aurora R8, I7-9700K, 32g memory, 1t NVMe boot drive, 2 - 1t SSD for MSFS, 1t SAT drive for storage, RTX 2070 Super 8g,

  7. #7
    Join Date
    Dec 2013
    Location
    nr Sacramento
    Posts
    157

    Default

    When I double click the MSFS Icon on the desktop, it will only open the Microsoft Store Showing the Gaming Services App install option.
    This is what I did to enable Microsoft Flight Simulator to open directly from a desktop icon.

    There are 4 or 5 Microsoft Apps in my “All Apps folder in File Explorer”, 2 of which are Microsoft Store and Microsoft Flight Simulator. The App that I chose to create a shortcut to my desktop (Figure C), was “Microsoft Flight Simulator”, not “Microsoft Store”.

    To view the Applications folder in Windows 10, press [Windows]+R, type shell:AppsFolder in the Open text box (Figure A), and press Enter. All your applications should appear in one scrollable window similar to (Figure B).

    Right click on Microsoft Flight Simulator app icon and select Create Shortcut, as shown in (Figure B).

    Ron M


    Name:  Short-Cut-a.jpg
Views: 376
Size:  67.8 KB

Similar Threads

  1. Replies: 2
    Last Post: 02-20-2021, 02:43 PM
  2. Microsoft Store Package Dependency Installer-- Avoid or say yes?
    By b3burner in forum Microsoft Flight Simulator 2020
    Replies: 2
    Last Post: 12-24-2020, 08:05 AM
  3. Replies: 6
    Last Post: 12-10-2020, 11:50 PM
  4. Replies: 10
    Last Post: 07-26-2017, 04:07 PM
  5. Replies: 6
    Last Post: 01-01-2002, 01:22 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •