Results 1 to 4 of 4

Thread: Ultimate Ground Crew X Update v1.7 Failed to Launch

  1. #1

    Default Ultimate Ground Crew X Update v1.7 Failed to Launch

    Hi ,

    I am running FSX-SE, FSUIPC4 v4.974, UGCX v1.7, AS16 and Active Sky Cloud Art, PMDG 747 QOS II Addon.

    When FSX launch, I am getting an error for UGCX.
    If you select 'Yes' FSX failed to load and crashed (Exit).
    If you select 'No' then FSX load normally, without UGCX.

    Have anyone seen this issue at all?

    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	UGCX v1.7 Error.JPG 
Views:	173 
Size:	120.9 KB 
ID:	216795  

  2. #2

    Have you looked here or tried the fs2crew support page???

  3. #3


    Hi ,

    Yes, also from the link you have shared.



  4. #4


    Hi ,

    I have managed to reach-out to Bryan York from FSCrew team.

    Here is the solutions:

    There's a bug in FSX itself that can sometimes result in this. It can affect all addons. Solution #3 seems to work best.

    Solution 1:

    1. Click "YES" when asked if you want to run the software. You'll may need keep selecting 'YES" until the simulator eventually stops asking you. This problem may be due to a rare Simconnect bug. Please read Pete Dowson's comments on this subject for more information (click the link).

    Solution 2:

    Windows may mark UGCX as unsafe because something caused an error in the previous load of Flight Simulator.

    1. Run "Regedit" and locate the setting for:

    HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers

    2. Edit the entry for FSX.exe or P3D.exe to REMOVE any mentions of UGCX.

    3. Restart FSX/P3D. You will get the error message again, but click Yes.

    Make sure FSX is running with Administrator rights.

    Solution 3:

    Open the DLL.XML file with Notepad. Rename the UGCX32.dll to: UGCX321.dll
    Then locate the UGCX.dll on your system and rename it to UGCX321.dll
    If you're using Steam, the dll will be here:

    \FSX\Ultimate Ground Crew X\UGCX32.dll

    In my case, Solution 3 seems to fixed it.


Similar Threads

  1. UASO Titan34D Launch Vehicle Completes Rollout To Launch Complex 40
    By kayamone sutton in forum Virtual Airlines
    Replies: 0
    Last Post: 03-11-2009, 03:22 PM
  2. to launch or not to launch...
    By Bomby in forum MSFS Screen Shot Forum
    Replies: 24
    Last Post: 03-08-2004, 01:38 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts