Results 1 to 9 of 9

Thread: Cannot start FS2004

  1. #1

    Unhappy Cannot start FS2004

    I have a new gaming computer, Dell Inspiron I5 core with NVIDIA GeForce GTX 1660Ti graphics card, so I know I have enough system to run my FS2004. When I loaded it and tried to run it I received a message saying something to the effect "Must have administrator permission to run the program". I've had FS2004 since if was first introduced. Now I get this message. Anybody have any ideas?

  2. #2
    Join Date
    Jan 2012
    Location
    Pontefract, West Yorkshire, UK
    Posts
    1,266

    Default

    As it is a new PC I assume that it has Win 10...…

    I also assume that you have installed FS2004 into the default location - i.e C:\Progam Files (x86)\…….

    Win 10 is a little bit more intrusive when it comes to security permissions. Try the following:

    Right click on either the FS2004 .exe file (located with the main FS2004 directory) or, if you have one, on the desktop shortcut. From the resulting menu list select Properties - a Properties window will open. Click on the Compatibility tab. Under the Settings section click in the box located to the left of the Run this program as an Administrator statement. Click Apply/OK. Test the sim.
    Regards

    Brian

  3. #3

    Default

    Totally frustrated!!.

    I've tried your fix and even re-installed program in a new folder titled "C:/FS9" and nothing seems to fix the problem.

    Microsoft's forced upgrade to another version of Windows sure has me hot under the collar!!

    Any other ideas?

    I purchased this new computer just for Flight Simulator and I can't get it to work.

    Thanks for everything you've done so far.

  4. Default

    Hi Jack,

    Perhaps this video link might provide some solutions,
    https://youtu.be/mEdjZYGvyiE
    Make sure you open in YT and use the dropdown "show more" to obtain the links to FlyAway Simulations page, mentioned in his video.

    I don't use Win10 or have FS9 installed anymore, but the problem is as Brian describes above an issue of permissions (Administrator Permissions) combined with the requirement that FS9 out of box installation needs (if I remember correctly) Disk 4 inserted in the CD/DVD drive for it to load. Or perhaps it was Disk 1, but I think D4 was correct. Even if you have upgraded From FS9 to FS9-v9.1 (Choose the right FAS FS9 update patch per your installation).
    To make matters worse for Win10 adopters, the Installation FS9/FS2004 itself needs to be installed with "Run As Administrator" privileges. Win7 8 & 10 also complicate this process even further for older programs where unsigned drivers & .dll (DynamicLinkLibraries) may be installed by such programs. Even more so the default enabling of the OS protection UAC (UserAccessControl), this facility can be switched off for Win7 8 & 10 by going to Windows >Settings >search - UAC select "Change User Access Control Settings" then move slider down to "Never Notify" then click OK to exit. You can then install things without Windows Unsigned driver notifications and interference from UAC.
    I certainly don't advocate the advice given in the video, always installed and used the software as intended without using such workarounds "No CD Patch" but it may be your only option moving forward with FS9 under Win10. The young fella talking in the vid seems to have a handle on the issue and solution found, perhaps it will also work for you.

  5. Default

    Jack,

    Here's a couple of links for FlyAwaySim, saves you searching around. Make sure your FS2004 is updated to v9.1 before you use the v9.1 Patch -(No CD)

    UPDATE: https://flyawaysimulation.com/downlo....1+Update&cat=

    PATCH: https://flyawaysimulation.com/downlo...1-no-cd-patch/

  6. #6

    Default

    1. Install into C:\
    NOT into the default C:\Program Files directory
    2. Install the 9.1 update
    3. Install the nocd patch for 9.1
    4. Right click the desktop FS2004 icon
    5. Select Properties
    6. Select the Compatibility tab
    7. From the pull down menu, select XP service pack 2, or any thing XP
    8. On the bottom of the Properties page, select Run as Administrator
    9. Double click the desktop FS2004 icon
    10. All should work..

    It's actually quicker to do than to explain.
    Robin
    Cape Town, South Africa

  7. #7

    Default

    Young man you "saved my bacon"!!!

    It works and I'm up and flying again.

    Thanks so much.

  8. Default

    Great news Jack, bacon saved, now you can safely store Disk 4 back in its case, after so many years of use its difficult to keep a single disk in a set of 4 safe from scratches and corruption. But at least now you can get back to flying with your new hardware. Thanks also to Robin.

    I'd be interested to know your experiences with the GTX1660Ti when you've had time to stretch its legs, it may be the next card I replace my GTX770, either that or a GTX1070Ti.

  9. #9

    Default

    Pleasure to have helped.

    Have fun flying!

    P.S....
    You can also have multiple installs of FS2004.
    Robin
    Cape Town, South Africa

Similar Threads

  1. Replies: 0
    Last Post: 04-21-2012, 04:53 PM
  2. Replies: 5
    Last Post: 12-31-2010, 03:47 PM
  3. cannot start in any europe airport
    By masterboy in forum FS2002
    Replies: 2
    Last Post: 03-14-2004, 03:50 PM
  4. HELP! Cannot start FS2002 anymore
    By keesvantil in forum FS2002
    Replies: 2
    Last Post: 11-03-2002, 02:54 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •