Results 1 to 5 of 5

Thread: Headset Problem

  1. #1

    Default Headset Problem

    Hi, I just bought a Logitech G433 Headset to use with X-Plane 11. It seems to work fine until I plug the mic boom into it. When I connect the mic boom I get a high pitched feedback. It only happen with X-Plane, but not with iTunes.

    Any idea what might be causing it?

    Thanks, Mike

  2. Default

    HI.
    The feedback is due to interference from two devices that use the the same amp. Make sure you are disabling the internal when you plug in the boom. You may have to do it in your PC, see if they show up as 2 devices and they are both enabled? It could be that The Itune is using / selecting one device only.

  3. #3

    Default

    Thanks for your reply. If I understand correctly your saying only one device should be enabled, which makes sense. However, when I go to System Preferences, I see a line that says "Internal Microphone" and another that says "G433 Gaming Headset", but no way to enable or disable either of them. So it appears that Im not able to do that, at least from what I can see

  4. Default

    Hi.
    You should be able to Right Click, if you are in the proper configuration and select Properties where you may be able to disable one or the other. More info on the OS, hardware etc needed. You may also be able to handle it in the Control Panel, Hardware and Sound, and or, Device manager, just be cautious.

  5. #5

    Default

    I have a Mac BTW, but thanks everyone for the help. I bought a new headset and it seems to work fine so far.

    My problem now is how to get rid of the ATC window that pops up when I key the mic. I logged on the Vatsim and ask for a radio check but get none. Just the AI ATC window keeps popping up. I unchecked the two bocks in setting/Sound for the ATC but I still get the window for ATC.

Similar Threads

  1. headset
    By kilmer in forum The Outer Marker
    Replies: 1
    Last Post: 01-06-2006, 01:47 PM
  2. If you're interested in buying a headset
    By LGA in forum The Outer Marker
    Replies: 6
    Last Post: 04-18-2005, 10:46 AM
  3. A good headset?
    By swva_pilot21 in forum The Outer Marker
    Replies: 6
    Last Post: 08-05-2004, 11:47 AM
  4. Anybody use a David Clarh H20-10XL headset?
    By squale in forum The Outer Marker
    Replies: 18
    Last Post: 04-05-2004, 01:38 AM
  5. REAL PILOTS - Headset question
    By Jeff S KDTW in forum FS2002
    Replies: 24
    Last Post: 01-04-2002, 09:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •