Page 1 of 2 1 2 LastLast
Results 1 to 10 of 18

Thread: saitek radio panel and instrument panel not working in fsx

  1. Default saitek radio panel and instrument panel not working in fsx


    it all used to work, but since reinstalling win7 I'm having the following difficulties:

    yoke + rudder pedals *almost* ok

    however, instrument + radio acting as if they are not even connected. Fsx won't see them

    I installed using saitek drivers, they both work and the test application shows tests them ok

    I uninstalled saitek drivers and put SPAD instead. the radio panel visible in spad but fsx won't use it.

    in the spad status bar I see that "flight sim version" and "aircraft in use" fields remain blank. but when i turn the knobs the spad promptly updates, so the device is ok.

    how can I go ahead and convince FSX to use them and activate them?

    on another note: I just noticed interference between rudder pedal brake action and left / right aileron yoke function. how can I tell fsx that brake is not yoke left/right? If I go to fsx settings and test the functionality, the axis dot moves as expected but in the game there is interference (brake left moves yoke left)

    separate question: I'm hoping to practice for my Multi Engine rating. but I only have one set of throttle levers. Do I need to spend another $50 to get a second set or it makes no big difference, I can always use the mouse to move throttles around as needed?


  2. #2
    Join Date
    Nov 2017
    Ii live on venus where we cook eggs on our heads.



    I have no clue about the instrument+radio, but about the throttle levers... If you don't want to spend a lot of money, I would just go with using the mouse, as it works fine enough for me. If you have a large budget in mind, then the throttle levers would be nice.

    I hope this helps,

  3. Default

    All the problems I've experienced have been to do with the USB ports. One thing or another typically stops working so I start fiddling with the plugs which apparently can confuse the poor computer so I have to uninstall and reinstall USB Drivers quite a lot. There is a known bug with the Saitek Multi Switch that stops the lights illuminating. This is solved by changing an entry in the Registry which of, course is cancelled out as soon as you start playing with the USB plugs.


  4. #4


    Hey Grid,

    Forgive me if you'd read me before on the topic of usb controls. I fixed almost all of my usb issues with FSX by using a powered usb hub. Less than $20 bucks.


  5. Default

    I've got 2 powered USB hubs. One in the Saitek Yoke and one I purchased separately. Problem is I no sooner fix one issue, lights not working for example than another pops up. Now the switch from standbye to active is not working and FSUIPC is not recognising one of the axiis although FSX sees it OK. I'm beginning to recall why I gave up on all this last year :-) The whole shooting match feels cobbled together in order to get it to work and playing around with config files, scripts and registries is not my idea of fun. This is why I'm tempted by X-Plane, the demo felt more robust.


  6. #6


    By experience, having help many friends configuring their "little cockpit";
    Saitek panels do not work well(or at all...) when connected to USB hubs. Too much data and
    power consumption I guess...
    We are all using SPAD for panels and some, not my case, have to use FSUIPC for fine tuning axis.
    We had similar problems as yours with a friend system to find out that his power supply was the issue.
    5 volt output was weak(under 3v).
    i7-4790K @4400 on Gigabyte Z97X (16gb), GeForce GTX 970 OC, Corsair Spec case
    Win7 Ult(64) on Samsung850 SSD(256), FSX+Accell on Samsung850 SSD(256), Track IR5
    Saitek yoke/rudder radio/multi/switch panels, Logitech G13, GMap on Samsung tab

  7. #7


    Hey Daniel,

    That's interesting! I'm using FSUIPC to control a yoke, rudders, throttle panel, and Multi-switch Panel, all by Saitek on my usb system.

    I also have multiple other inputs: my home weather station, mouse, keyboard, printer, a microphone and earphone unit, & a cell-phone charger plus a charger for my tablet, which I use as a 4th screen when flying, which all run on the same usb as well. Oh yes, I also have a 2 tb back-up external hard drive on that system as well.

    I'm not saying everything on usb runs all the time. But several things, such as the back-up hard drive are always on. I've run this or a very similar setup for say three years + or - on at least four different desk style computers with no issues once I installed the powered usb hub-s.

    Which-what 5vlt power supply are you referring to?

    Last edited by Rupert; 02-11-2018 at 03:48 PM. Reason: add the tablet & hard-drive

  8. #8


    Hello Rupert, you probably know that most PSU have four different outputs; 2X12v(+ and -), 1X5v and
    1X3.3v. My friend's PSU was "dying"...
    The lack of current was not a problem for his mouse, yoke, rudders and even trackIR. But it was for
    the multi and radio panels. (Didn't light up or acting weird) It took a while to find out the source..!
    As for the use of USB hubs, I saw more than once that those panels(multi &radio) are "allergic" to
    be connected on the same multiple hubs. Strangely, it was working fine on FS2004 but not with FSX...
    For FSUIPC, I never had to fool with it for my own set-up.. I have it because it's mandatory to FSX.
    I prefer SPAD to take care of the panels management. Simple and efficient enough for me.
    But some of my pals have a preference to use it. We got each of us, our recipe to enjoy FSX and
    make it work...
    And I was just trying to help...
    i7-4790K @4400 on Gigabyte Z97X (16gb), GeForce GTX 970 OC, Corsair Spec case
    Win7 Ult(64) on Samsung850 SSD(256), FSX+Accell on Samsung850 SSD(256), Track IR5
    Saitek yoke/rudder radio/multi/switch panels, Logitech G13, GMap on Samsung tab

  9. #9


    I have had my panels for about 10 years. I have the power adapter for the yoke and have my panels plugged in to the powered USB on the yoke. I have never ever had a problem with my panels working. For FSX I use spad. Not and no saitek or logitech drivers installed. For P3D V4 I use Linda which is free and works great. My yoke then plugs in to a NON powered usb hub that connects to my computer. This is also the hub my rudder panels and TrackiR are connected to.

    First thing make sure you uninstall any logitech or saitek drivers for them. They never worked properly anyway.
    Next go to and get the last release of Spad.
    Make sure you have the most recent FSUIPC for your simulator.
    Walla! It should work!

    As far as the power supply topic it should never be a problem if you build your system with a power supply with a 20% overhead. Always put in more then you will need just in case.

    Ross G.

  10. Default

    I will try all these things but first I need to clarify one thing:

    SPAD sees the radio panel OK and the radio panel tests ok using the SPAD test.

    also the instrument panel lights up and it shows the logo and I can cycle through the various instruments up and down.

    So these two are ON and POWERED but the FSX is not taking control of them. Even SPAD says that there is no FSX connected. So I don't think this is on the driver/usb/power side but somewhere between FSX and the drivers. Is there any way I could point FSX to load connect to these two devices?


Page 1 of 2 1 2 LastLast

Similar Threads

  1. Replies: 1
    Last Post: 02-05-2018, 07:33 PM
  2. Does anyone have an AFCAD for KORD working in V4
    By dfreemanfso in forum Prepar3D
    Replies: 0
    Last Post: 01-14-2018, 12:58 PM
  3. please please Saitek instrument fip not working in FSX
    By Remfur143 in forum PC Hardware, Video And Audio Help
    Replies: 2
    Last Post: 07-22-2015, 05:27 PM
  4. Saitek pro flight multi and switch panel not working in FSX SE
    By Bobob22 in forum PC Hardware, Video And Audio Help
    Replies: 0
    Last Post: 04-05-2015, 01:57 PM
  5. Replies: 12
    Last Post: 04-01-2014, 01:20 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts