Results 1 to 4 of 4

Thread: Hardware partially working

  1. #1
    Join Date
    Apr 2017
    Location
    Snohomish, WA
    Posts
    23

    Default Hardware partially working

    I recently had to reinstall everything FSX after my computer wound up having a problem and I had to get a second one. This one seems to work okay but when I installed the drivers for my Saitek radio panel and switch panel, only some of the functions are working inside of FSX. When I use the test tool that was installed everything works fine, well except for one switch on the switch panel but I don't think that's the problem. For example, the Off, R, L, Both/All, Start rotating switch works just fine but none of the light switches work. On the radio panel I can dial in a new frequency on the standby side but when I try to switch it between standby and active it does nothing. I can see the number changing on the computer and if I click the arrow on the radio in the panel of the aircraft, it switches so it is "working" to some extent. I reloaded the drivers and it didn't make any difference. Has anyone experienced this before and if so was there a solution.

    FSX Gold, Windows 10.

    Thank you,

  2. #2

    Default

    Buy a "usb multiple hubs with external power". Do not feed power from main PC power supply. Good news: They are cheap.

    Cheers,

  3. #3
    Join Date
    Apr 2017
    Location
    Snohomish, WA
    Posts
    23

    Default

    Thanks. Unfortunately I already am using one.

  4. #4
    Join Date
    Apr 2017
    Location
    Snohomish, WA
    Posts
    23

    Default

    Update. I found another post in the forums that solved the problem. I clicked on the lower left icon on the Windows toolbar and from the list of programs opened Saitek and clicked on Start Switch Panel Manually, or something to that effect. Sorry, I'm not on my home PC so I don't have Win 10 or FSX available right now. Anyway, this wound up making all the switches work and the toggle frequency button work on my radio panel.

Similar Threads

  1. AI Traffic Partially Lost
    By B757 FO in forum FS2002
    Replies: 3
    Last Post: 08-10-2004, 01:45 PM
  2. Replies: 1
    Last Post: 02-16-2004, 03:44 PM
  3. Partially Depicted Buildings
    By av84fun in forum FS2004
    Replies: 0
    Last Post: 08-04-2003, 10:21 PM
  4. Replies: 0
    Last Post: 06-11-2002, 08:58 PM
  5. instrument stack partially dissapears
    By jgriffin92 in forum FS2002
    Replies: 0
    Last Post: 02-05-2002, 10:49 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •