Results 1 to 7 of 7

Thread: *** Problem with Garmin Trainer in FSX? PLEASE READ ***

  1. #1
    Join Date
    Mar 1997
    Boca Raton, FL, Based at KBCT

    Default *** Problem with Garmin Trainer in FSX? PLEASE READ ***


    - When launching the installer, DO select the "Garmin Trainer" install option in the RXP installer. It will copy the installer files into the following folder in case you need to reinstall the trainer only directly.

    C:\Documents and Settings\All Users\Application Data\Reality XP\Common\GnsTrainer\Inst430

    If you do select the option, the installer will also AUTOMATICALLY start the Trainer installer. At this stage, when the Garmin installer prompts you, CHOOSE a simple folder with less than 8 chars. We recommend:


    This shall solve all your issues.

    NB: the reason for the issue is Vista UAC. We do include a small program in the installer that is supposed to change the folder access rights, but it seems it may not be working properly for now.

    For the most technical readers, this program is copied into your:

    C:\Documents and Settings\All Users\Application Data\Reality XP\Common\GnsTrainer\

    The filename is: chgTrainerRights.exe

    You can try reinstalling the Trainer in the default folder, then open a console window, launch the program with the trainer installation folder as command line, like:

    chgTrainerRights.exe C:\Program Files\Garmin\GARMIN 400 Series Trainer\

    in order to see if this works on your system.

    2) for the "FPL LOCK" message, please, as mentioned in the Dakota User's Manual, download and read the Garmin Manual. Basically, it means you are loading the GNS with a flight plan, which is using a waypoint not found in the database. You can choose which database you want the GNS to run with. This message is normal.


    Jean-Luc Dupiot
    Reality XP
    Lou Betti

  2. #2

    Default Trouble getting GNS 430 running in Dakota FSX

    Lou - I have just installed Dakota FSX with no obvious problems, but after selecting it in FSX then pressing fly I get the message - 'Reality XP Garmin GNS 430 Ver. can't start the reality XP Garmin - error 3524. The FSX crashes out after windows gives up trying to 'fix the problem'.

    I am running FSX with Acceleration installed.

    Any suggestions would be much appreciated - like where do I go, which file in FSX to see if Garmin is installed correctly.

    Many thanks


  3. #3
    Join Date
    Apr 2007

    Default Problems with Dakota FSX

    Hello Lou!
    Firstly, I am a very satisfied customer of your products for FS2004!
    They were wonderful! The two Archer II & III helped me greatly in learning flying for real … (I am a student pilot aged 50 years old…). I was so happy that I dis quite a lot of repaints and you can’t imagine how many flying clubs here in Switzerland ask me a repaint of their club aircrafts. Your Archer III was a real success amongst real pilots!
    Now I have a new computer as following:

    550 W thermaltake
    Asus P5K mainboard
    Dualcore E6750
    4 GB ram
    2 HD 2x500 GB
    Nvidia Gforce GTS 640mb

    FSX with patch 1+2 installed and several add on that run ok!

    I then purchaised the Dakota for FXS and …. How many problems!

    The first time I installed it crashed immediatly, then I switched off UAC and the load problems were solved, but the aircraft had several problems, gauge not running or disappered …. a real chaos.

    Then I unistalled the aircraft, FSX also, reinstalled in another drive FSX, patch1, patch2, no other add on …. Then installed your new patch.
    The Dakota was okay, running good, the control-center was finally running without crashing, alla options ok….. wow I was really happy.
    In comparison with the Carenado Cherookee it was only 5-8 FPS slower ….. in a brief test run, and I also coluld switch between an aircraft and another ………… problems!

    After 2 days I have again problems, I don’t know why! I reinstalled the patch as for your instructions and the aircraft run again at least rather ok, the control center run ok, but at the start come a message stating the impossibility to load the garmin, I clik on OK and start loading the aircraft…. Take long time to load however…………….
    In the control center I must not check the garmin option or freeze immediatly ……
    I have done two short flight, only to see if it run, yes, run, but the frame rate is rather strange, change continuosly from 7 to 30 - 50 FPS, with shuttering, without reasons, almost impossible to fly …. really strange thing.
    Where the carendo Cherookee have always 50-60 FPS almost without change in framerates your aircraft run continuously between 7 and 50 ….. and the first time I installed the patch instead was running good ……what’s happened? I have no idea….
    What I do, reinstall it for the third time? And how many time can i Install/reinstall my Dakota?

    All other add ons that I have installed in the meantime are running wery good … only Realyty XP gauges show problems, it’s a shame, thea are so realistic …..

    Well, I hope you will manage fo find a solution, in the meantime I don’t know if I will fly again with the Dakota …..and it’a a shame.

    Second questions.: as usual your repaints are rather bad, there are always errors in your paint schemes ……… even in the good Archer III was the same …. Swiss and italian Archer III had several errors and I did them again with the right colours …. You shouild pay mach more attention in the painting, there are so many photos avalaible on , from every angle …….

    Well now it’a time to stop …. Hope to hear news from you and your team, don’t give up! I’m waiting for the new dreammanager , I with to do at least 7 swiss livery repaints of your Dakota!

    With my compliments

    Antonio Iozzi
    Attached Thumbnails Attached Thumbnails Dakota erron closing FSX 005.jpg   Dakota eror loading 003.jpg   Dakota error - loading 001.jpg  

    dakota error- fron control center 004.jpg   erron closing FSX.jpg   garmin error - Piper dakota FSX.jpg  

    Dakota error loading 002.jpg  

  4. #4
    Join Date
    Mar 2005
    Richmond, Surrey, United Kingdom.

    Default Problem with Garmin Trainer

    I have just bought a Dakota.

    The install failed at 'GNS Trainer\CHGT..' .when I was left with a black screen and a blinking 'C'.

    When I tried to run it in SP2, I got "Can't find the Garmin Trainer 430 program. Check registry or reinstall."

    I know nothing about the registry, and there seemed no point in a reinstall. .

    I have tried your recommendation of going into Cocuments and settings...GnsTrainer\Inst 430. Selecting the option does not, as you say, automatically start the Trainer installer. And double-clicking on the exe icon has absolutely no effect.

    So it does not, as you claim, solve all issues.

    In all my years of simming, I have never before been so totally let down by a payware aircraft - or, indeed, a freeware aircraft.

    Please let me know how to secure a refund.
    Last edited by Phiz; 07-10-2008 at 01:49 PM.

  5. #5
    Join Date
    Feb 2007
    Danielson, CT

    Default Garmen GNS430 Ver.

    Just installed DreamFleet Dakota. When I try selection the aircraft in FSX I get the following: "Can't start the Reality XP Garmen" - Error 3524. What's wrong??????
    I am 73 and retired living on a fixed income and money does not come easy. Flight simmimg is a great way to help pass the time and I put my trust in the addon suppliers to give me a product that works. I should not have to go through this to get things to work properly. I paid good money ($34.95) for this program and have problems getting to run. I would not expect this from DreamFleet.
    If DreamFleet cannot correct this problem within a reasonable amount of time then I want to know what I have to go through to get a refund.

    Thnk you

    Stan Fox

    [email protected]
    Last edited by cyfox2; 08-13-2008 at 06:58 PM.

  6. #6
    Join Date
    Dec 2005
    Ft Lauderdale, Florida, USA.

    Default Fix worked on Garmin but other issues remain


    I changed the folder name and finally I was able to start FSX and the Dakota with no Garmin errors however, on my Vista 32 machine I get the following issues only in the Dakota:

    1) When I pull up the plane's config screen I can't make any changes or switch pages
    2) I can't turn the starter either in the main panel or in the Vc (I have to use Control+E)
    3) There is no Avionics switch available, just a black hole so I can't turn on some of my other gauges or equipment
    4) Can't see a Prop or Mix or Throttle lever.

    Otherwise, she flys great!


  7. #7
    Join Date
    Mar 2005
    Snohomish, WA, USA.

    Default Deja Vu

    {{ 1) When I pull up the plane's config screen I can't make any changes or switch pages
    2) I can't turn the starter either in the main panel or in the Vc (I have to use Control+E)
    3) There is no Avionics switch available, just a black hole so I can't turn on some of my other gauges or equipment
    4) Can't see a Prop or Mix or Throttle lever. }}


    I have the same 4 exact problems. I see you posted in August. Any fixes yet? I had some other issues, but one by one, I'm knocking them out.

    The final solution was to disable Vista's UAC, and reinstall the aircraft. Then I was able to re-enable UAC with no other apparent problems.

    Loren Cole
    Snohomish WA
    Last edited by LCole; 02-10-2009 at 04:04 PM. Reason: The fix

Similar Threads

  1. Is it possible to use the Garmin trainer downloaded directly from Garmin?
    By edga23 in forum DreamFleet General Discussion Forum
    Replies: 2
    Last Post: 07-17-2012, 07:30 AM
  2. Bonanza and Archer III Garmin Trainer problem
    By updraft in forum DreamFleet General Aviation Support Forum
    Replies: 8
    Last Post: 09-13-2007, 09:01 AM
  3. A36 Garmin Trainer installation problem
    By Scouseair68 in forum DreamFleet General Aviation Support Forum
    Replies: 6
    Last Post: 04-28-2007, 10:30 AM
  4. Garmin GNS430 & 530: Trouble installing Garmin Trainer
    By DreamFleet1 in forum FAQ - Frequently Asked Questions - DreamFleet General Aviation & 737-400 Products
    Replies: 0
    Last Post: 10-07-2005, 04:14 PM
  5. PLEASE READ - Arabian Paint Services - PLEASE READ
    By Arabian in forum Virtual Airlines
    Replies: 1
    Last Post: 01-11-2005, 03:18 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts