As some of you may have discovered, Garmin has updated the data base to their Garmin GNS530 trainer, however, this latest trainer / database is not included with the Baron 58.

Why?

Because we have not had time to fully test it, and also because this database will be much different than what is found in FS2004. The older data base is closer to what is found in FS2004, and for the majority of customers, this data base will serve their needs.

If you wish to upgrade your trainer to the latest version in order to get this new data base, feel free to do so, but at present we cannot guarantee support for the Reality XP Garmin 530 should problems occur because of this upgrade.