Jump to content

Can't install fsx in Win 10


ntai

Recommended Posts

Hi folks,

Today i did a refresh of windows 10 but can't install fsx now. Previously it worked fine but that was an upgrade from win 8.1. The installation gets all the way to the end then i get two error messages.

"Error 1722 there is a problem with the windows installer package. A program run as part of the set up did not finish as expected. Contact your support personnel or package vendor" When i acknowledge this another one pops up saying

"Error 1603 fatal error on instillation"

A web search reveals very little information for windows 10. Any help would be greatly appreciated.

Link to comment
Share on other sites

Ah, there they are again, 1722 and 1603. Was starting to miss them, it's been a while...

 

 

 

You probably ran the installer twice. Cancelled the first time and tried again.

 

The first time it was run it already installed the fsx registry entry's. Now windows thinks fsx is already installed. So it won't install 'again', giving you the 1722 / 1603 messages.

 

Meaning you now first need to clean the registry.

 

NOT with a reg-cleaner program. NO. And NOT manually either. NO. (expletives deleted)

 

There is a specific cleaner tool, just for fsx. Made by Microsoft, and working fantastically.

 

See here for how to fix:

https://www.flightsim.com/vbfs/showthread.php?279451-How-to-clean-up-the-registry-after-uninstall

[sIGPIC][/sIGPIC]
Link to comment
Share on other sites

Thanks for your response and link. Unfortunately, no luck same error messages. I notice the fsx window says (after the error messages) "the wizard was interrupted before Microsoft flight simulator X could be completely installed/uninstalled"
Link to comment
Share on other sites

Thanks for your patience,

I try to run the program but i get only a flash on the screen that looks like command prompt. Anyway, i go to command prompt and attempt to enter the info from the OP buut it has no idea what i am typing. I follow the Microsoft instructions and get the success message.

Link to comment
Share on other sites

Sorry abot simply linking. Reading an older post can be confusing.

 

There are two stages to kb928080.

-1-

You place the downloaded file on the desktop. Then you run that.

A auto-exractor program opens,

that will put the files that will be used to reset on your C:\ drive.

It places those in a folder it creates:

C:\MicrosoftKB928080

 

 

-2-

You open a command prompt. (You do this yourself, from the Start button. Just type cmd.

In a list of searc results cmd.exe appears.

You then right click cmd.exe

and select "run as administrator".

 

 

-3-

Then inside the cmd prompt you type the commands as listed.

What the commands do:

the commands basically:

>go to C:\

>open folder C:\MicrosoftKB928080

>run file Resetdll.exe

>with the added switch -All

 

------------------------------------------------

As you say you got the SUCCESS message in the command prompt, I think you did that correctly.

If you try installing again, do you still get the 1722 and 1603 errors?

Have you tried rebooting inbetween yet?

 

 

Just in case, here is what a command prompt looks like:

(I hope this link works...)

 

http://www.bing.com/images/search?q=admin+cmd+prompt&view=detailv2&&id=229F225CAB043F3A720FB0DB9F6153B5DC51D29F&selectedIndex=10&ccid=j0FMddvq&simid=608013047397353833&thid=OIP.M8f414c75dbea6d771e23bd753fdef4eao0

[sIGPIC][/sIGPIC]
Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...