Jump to content

Simconnect failures when fiying online


Recommended Posts

I've updated to Win 10, reinstalled FSX, updates and X pack. I'm getting intermittent exception handler failures during online flights. The details of the failure calls out Simconnect. I'll clip out the details for another post

When I looked for Simconnect on the hardrive, I found three

Xpack Version 10.0.61637.0

Sp1 Version 10.0.61355.0

FSX version 10.0.60905

Is there a conflict having all three?

Could this be causes the problem?


here's the details

************** Exception Text **************

System.Runtime.InteropServices.COMException (0xC000014B): Exception from HRESULT: 0xC000014B

at System.Runtime.InteropServices.Marshal.ThrowExceptionForHRInternal(Int32 errorCode, IntPtr errorInfo)

at Microsoft.FlightSimulator.SimConnect.SimConnect.RequestDataOnSimObjectType(Enum RequestID, Enum DefineID, UInt32 dwRadiusMeters, SIMCONNECT_SIMOBJECT_TYPE type)

at bo.x()

at by.h(Object A_0, EventArgs A_1)

at System.Windows.Forms.Timer.OnTick(EventArgs e)

at System.Windows.Forms.Timer.TimerNativeWindow.WndProc(Message& m)

at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)



this happens with Vpilot or Squawkbox

Link to comment
Share on other sites


that was true, FSX just restarted with SB. I was able to sit at IAH last night with either SB (very jerky video) or Vpilot for over a half hour of watching people TO and arrive without a failure. going to test some more tonight.



I was not able to rename that Simconnect. I need to look at its security.

Link to comment
Share on other sites

I have no idea if renaming simconnect.dll would do it. Or if more is required.


I think if SP1 is relly the issue, the best way may be to uninstall fsx, and then to only install deluxe and acceleration. (no sp1)

But I'm not completely sure if sp1 is really a problem.


I'm really not experienced with simconnect errors. It's always just worked for me. But then again, I always stuck to only installing deluxe and acceleration.


(Once I installed deluxe and sp1 and sp2.

But that time no acceleration.

That worked.

But I soon removed it all and did the normal install instead, because I realised that way the Fa18 and some more is not included.

Again, it was not related to simconnect.)


With the vatsim clients I also have hardly any experience. Years ago I got onto Vatsim. But just two or three flights.

Again, it worked out of the box, so, hard to advise.

(It was also several years ago.)



I just read your post and spotted: deluxe - sp1 - and accel. And thought it may be a conflict.

No real suggestions, sorry.


And advising to uninstall fsx may not be wise either. I avoid advising that as much as possible, and advising it here is probably wrong as well. Especially if you have a lot of other addons installed. There may be a very easy fix.


As you now manage to connect it seems to be working (at least for a while), so based on that there is no reason to uninstall/reinstall.

There may be a different issue.

Things that happen at Vatsim (if I remember correctly):

-If you just sit around at an airport you can get kicked off the session, because you take up bandwidth without playing.

-Some aircraft may be incompatible. (also kicked off the session.)

-Someone crashes into you and you didn't see them coming.


Reinstalling is always a last resort. Often things are fixable. And you also learn much more by fixing.

Link to comment
Share on other sites

thanks il88pp for your suggestions -

I found a CTD (crash to desktop) manual at Avsim. I've started doing some of the things they suggested and will post if I have success.

Last night I was able to stay online for a flight over an hour, so maybe some of that helped.


Link to comment
Share on other sites



FWIW, here is what happens:


The exception / "error message" you are seeing is thrown by SimConnect itself. It seems to have problems communicating with the sim - this can happen, when it is flooded with requests, maybe from another addon doing the same thing, or running a different "incarnation" of the SimConnect client.


At least one of your addon apps (VPilot or Squawkbox) is a managed (C#/ dotNet) app, that uses the equally managed Microsoft.FlightSimulator.SimConnect.dll. The addon either has the DLL included or relies on you to have it installed. If installed, the managed DLL is not only called at runtime, but it is an dotNet "assembly" installed in the GAC on your system. No amount of renaming will change that, you would have to either uninstall it in the control panel or prevent the app from calling it. Both are no viable options IMO.


But I could imagine that this is actually a dotNet issue on Win10. The older SimConnect client/DLL (FSX boxed) is based on dotNet 2.0, so it may lead to trouble running them on Win 10. You might have to additionaly install dotNet 2.0. The newer incarnations (FSX Steam and P3D) are based on dotNet 4.0, these should be fine.

Link to comment
Share on other sites


thanks for the reply

I'll look into DotNet upgrade and verify that no other app is calling for Simconnect.

the only one I believe I have that I'm not presently using is FaceTrackNoIR.

My old webcam will not work with Win 10.


BTW I do like Win 10 but it sure took some massaging to get old stuff to work

thanks Again


Link to comment
Share on other sites

thanks to all, for the info

after posting a couple of places online, most responses say

It appears my problem is my network and possibly our Uverse gateway.

I am updating it and getting a faster connection rate.

Hopefully, I'll be able to get back to regular online flying soon.

thanks again


Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...