Jump to content

FSX not installing on Win7 64 bit fresh install.


Recommended Posts

Hello Aviators,


I have a Toshiba Satellite Core i5 2410M @2.3GHz, 4 GB RAM, NVidia on board with 2 GB VRAM, with a fresh Win 7 64 bit install.

My FSX, which was doing fine on Win 7 32 bit, doesn't complete the install now and gives an error somewhere in the middle of Second DVD install. It asks me to mount the Disc 2 again, when it is already mounted (in Daemon Tools Lite 10.1 Virtual Drive). I keep clicking OK but nothing happens and the install is stuck there.(image attached).

I also have X Plane 10 installed on my system (no probs there).

I have tried installing:

a) from two different sets of DVDs, which worked fine on 32 bit installations on multiple computers

b) into a separate folder on C: (C:/FSX)

c) after uninstalling previous failed installs using Microsoft Uninstall Utility (to remove any bits left onboard)

d) after installing MSMXL from Microsoft Support Site

e) after updating all Window Updates after my fresh 64 bit install

f) as an Administrator


Kindly advise.




Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...