Jump to content

FSX - Crash to Desktop - but event log entry ?


poolep

Recommended Posts

I happily had FSX running on my PC with Windows 7.

 

A graphics card problem saw me wipe the PC clean to ensure that it was hardware rather than software.

 

Now I have a new graphics card and Windows 10.

 

I've reinstalled FSX and all seems well until the sim hangs mid flight for a few seconds then reverts to the desktop. Generally there is no event or message in the Event Log. Once I did get somethinng about my PC being unable to connect to some service or other (it seemed that it was trying to connect to some Internet service at the time of the crash).

 

I have :-

Windows 10

FSX Deluxe edition with the accelleration pack installed.

PMDG 737 NGX

FS Passengers

Traffic X

 

Nvidia GeForce GTX 750 Ti

Intel i7-3770 CPU 3.5Ghz - overclocked to 3.7Ghz

16Gb Ram

 

I have downloaded and used Jesus Bojote's FSX tweaking tool (as before) and also put the UIAutomationcore.dll into my FSX folder.

 

FSX is installed into it's own folder on my main hard drive.

 

The sim can last for 10 minutes or 40 minutes before a CTD.

 

Any suggestions please ?

Link to comment
Share on other sites

Just done a recent flight and, in the event log I had the same Event Log entry 12 times whilst FSX was running.

 

Sometimes 3 mins apart - sometimes 15 mins apart. I had FSX running for about 50 mins before a Crash to Desktop - but no error message was shown.

 

System

 

- Provider

 

[ Name] Microsoft-Windows-DistributedCOM

[ Guid] {1B562E86-B7AA-4131-BADC-B6F3A001407E}

[ EventSourceName] DCOM

 

- EventID 10016

 

[ Qualifiers] 0

 

Version 0

 

Level 2

 

Task 0

 

Opcode 0

 

Keywords 0x8080000000000000

 

- TimeCreated

 

[ SystemTime] 2015-09-11T05:23:39.888849100Z

 

EventRecordID 6301

 

Correlation

 

- Execution

 

[ ProcessID] 936

[ ThreadID] 984

 

Channel System

 

Computer Peter-PC

 

- Security

 

[ UserID] S-1-5-19

 

 

- EventData

 

param1 application-specific

param2 Local

param3 Activation

param4 {6B3B8D23-FA8D-40B9-8DBD-B950333E2C52}

param5 {4839DDB7-58C2-48F5-8283-E1D1807D0D7D}

param6 NT AUTHORITY

param7 LOCAL SERVICE

param8 S-1-5-19

param9 LocalHost (Using LRPC)

param10 Unavailable

param11 Unavailable

 

Could this be the casue of my problem ?

Link to comment
Share on other sites

Excuse my ignorance, but what I posted is the only information I could find in the event log.

 

Is there somewhere else I should be looking ?

 

The same error started appearing when I started FSX and I've not had the same error appear in the event log since I stopped using FSX

Link to comment
Share on other sites

Does this relate to anything ?

 

System

 

- Provider

 

[ Name] Service Control Manager

[ Guid] {555908d1-a6d7-4695-8e1e-26931d2012f4}

[ EventSourceName] Service Control Manager

 

- EventID 7031

 

[ Qualifiers] 49152

 

Version 0

 

Level 2

 

Task 0

 

Opcode 0

 

Keywords 0x8080000000000000

 

- TimeCreated

 

[ SystemTime] 2015-09-13T06:26:17.838559800Z

 

EventRecordID 6435

 

Correlation

 

- Execution

 

[ ProcessID] 776

[ ThreadID] 860

 

Channel System

 

Computer Peter-PC

 

Security

 

 

- EventData

 

param1 Sync Host_Session1

param2 1

param3 10000

param4 1

param5 Restart the service

4F006E006500530079006E0063005300760063005F00530065007300730069006F006E0031000000

 

 

--------------------------------------------------------------------------------

 

Binary data:

 

 

In Words

 

0000: 006E004F 00530065 006E0079 00530063

0010: 00630076 0053005F 00730065 00690073

0020: 006E006F 00000031

 

 

In Bytes

 

0000: 4F 00 6E 00 65 00 53 00 O.n.e.S.

0008: 79 00 6E 00 63 00 53 00 y.n.c.S.

0010: 76 00 63 00 5F 00 53 00 v.c._.S.

0018: 65 00 73 00 73 00 69 00 e.s.s.i.

0020: 6F 00 6E 00 31 00 00 00 o.n.1...

 

The machine-default permission settings do not grant Local Activation permission for the COM Server application with CLSID

{C2F03A33-21F5-47FA-B4BB-156362A2F239}

and APPID

{316CDED5-E4AE-4B15-9113-7055D84DCC97}

to the user Peter-PC\Peter SID (S-1-5-21-3162420077-3863142204-3245546244-1000) from address LocalHost (Using LRPC) running in the application container Microsoft.WindowsStore_2015.8.25.0_x64__8wekyb3d8bbwe SID (S-1-15-2-1609473798-1231923017-684268153-4268514328-882773646-2760585773-1760938157). This security permission can be modified using the Component Services administrative tool.

Link to comment
Share on other sites

The problem appears to be related to User permissions on the computer itself. I would suggest you first search the registry for the CLSID and see which service or component it refers to, then look for that in the list of components in DCOM.

 

Otherwise, two options that may fix the problem are:

 

1. Simple solution. If your user account is a standard user account either create a new Admin account or change the standard account to an admin account. But be aware of the following: PROs: An admin account means that you will never have to run/install programs using the right click 'run as admin' option. CONs: Using an admin account as a standard account can leave you a little more open to security/hacking threats - easily mitigated by having a AV/antimalware suite installed.

 

Also note, that once a standard user account has been changed to an Admin account it cannot be changed back to a user account

 

2. Complex: change the permission of the CLSID and APPID.

 

Before undertaking this option I strongly suggest making a backup of the registry AND/or manually creating a windows restore point.

 

For a full explanation of what it means and how to do so see:

 

http://www.eventid.net/display-eventid-10016-source-DCOM-eventno-4718-phase-1.htm

 

and

 

https://social.technet.microsoft.com/Forums/windowsserver/en-US/4763f80d-d113-4ddc-8578-01bbf4152e31/event-id-10016-dcom-error-source-microsoftwindowsdistributedcom-level-error?forum=winserverDS

Regards

 

Brian

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...