Jump to content

Strange FSX/AI Aircraft Behaviour and CTD (NTDLL.DLL)

Recommended Posts

My FSX Game was working perfectly a few months ago, and before Christmas 2022, without any hitches. But now, FSX seems to be crashing randomly after changing/switching through menus, and AI Traffic bounce up and down along each airport's apron, and do twirls in the air. I don't have any clue what has happened, or what has changed. After a few minutes of switching between menus, and viewing nearby airports.

The FSX Application crashes to Desktop, and Event Viewer gives the faulting module as NTDLL.DLL. I have tried reinstalling FSX Steam Edition via Steam, using UIAutomationcore (386 Version), purging and resetting my FSX Microsoft Roaming Folder and Cache, and I've even reinstalled Windows 10, to no avail. The problems still persist. Also, when I view certain AI Aircraft that are already in the air, and are enroute to their destinations, in the simulation/game, I often find them not too far from each other, and they are rotating on their X axis, and sometimes fly inverted. And then the just drop out of the sky, and disappear altogether.

Also when I try and take off, no matter which aircraft it is, eg a FAIB 737, 747 or 757, or even an DJC/FSPXAI airbus A319, A320 or A321, any aircraft at all, the right or left engine, only always one of them, is never on, and I have to keep pressing the engine on hotkey, but even still, with both engines at maximum, the different aircrafts only can reach about/between 65-85 knots, and the nose of the aircraft just is raised in the air. I have even tried crashing in water, to see what would happen, it respawns in the air above the water, at it's top speed, but then quickly slows down and stalls and then falls back to the ground/water.

I have checked all of the aircraft.cfg and .air files, for all of the aircraft, land vehicles and rotorcraft. They all seem fine, however I noticed when opening up the "Fuel and Payload Settings", via the FSX Simulation Home/Selection Screen, that most of the weight is shunted to the front-middle side of the plane, and it says that the aircraft weight is some ridiculous figure like "127,625lbs over its maximum take off weight", even though I never changed any of those settings on any of the default or AI Traffic Aircraft. I do have images of the bizarre activity, but I cannot seem to find a way to upload them to this support thread. Any help or advice on my issues experienced, would be enormously appreciated.










Link to comment
Share on other sites

Any chance you may have downloaded and installed an addon program or scenery for FSX, tried it, didn't like it, and then tried deleting it? It may have left residual yuk in your Sim.  Have you tried running Verify files?  I don't think doing a re-install would get rid of the funky stuff.


To verify your game files please do the following:

1. Load the Steam platform and log into your account
2. Click the Library tab in the menu at the top of the screen
3. Click the List View from the view options on the top right of the screen
4. Right click on Microsoft Flight Simulator X: Steam Edition to bring up a popup menu
5. Click on Properties from the popup menu to bring up another popup box
6. Click on Local files from the popup box menu
7. Click on Verify integrity of game cache from the Local file options
8. Wait for the progress bar to finish verifying your files. Additional files may download
9. Restart Steam
10. Restart Microsoft Flight Simulator X: Steam Edition 


1. Log on to Steam
2. Select "View Games Library" from the "Games" menu
3. Right-click the Microsoft Flight Simulator X: Steam Edition icon and select "Properties"
4. Select the "Local Files" tab and click on "Verify Integrity of Games Cache"

Still thinking about a new flightsim only computer!  ✈️

Link to comment
Share on other sites

Hi again everyone...


I did what you suggested, but it didn't work. and upon loading the game, it crashed around after 5-10 minutes after loading. So i then tried and removing certain scenery folders, and removing them from the cache too. It didn't work when I removed the freeware scenery files, that I downloaded, but when i removed each of my UK2000 scenery files, including the HD ones. This time there appeared to be a 50% improvement, the AI traffic was no longer tipped up in the air, but they were flying more level, but they were fairly wobbly in flight, but no disappearing or falling etc, or doing loop-the-loops. So Im not sure at all, what has happened here.

Link to comment
Share on other sites

Hi there,


It may also be, that you were correct in that it might be a scenery file issue. As the only files, that were still reenabled in the game, were my personal work flightplans, and the world AI traffic files, such as easyjet, AA, United, vueling and all sorts etc. eg, individual traffic files, with the repaints installed manually. and my airport scenery files, other than that, i am sure that nothing else was still there, after the installations of FSX and Windows 10. So it could be that it may be that a recent windows update, specific to my old PC, may not be totally compatible now with some of the UK2000 scenery. but i will investigate more, and report back on here soon.

  • Like 1
Link to comment
Share on other sites

Hello there again,


I have now solved the issue, I believe so far. It was some kind of issue with UK2000 scenery. i have now checked all of my ai traffic and pretty much all of them are now working perfectly with no hitches, including on the airport apron or in the air, and so far FSX has not crashed within 20 minutes or so. and it a lot more stable it seems, with graphics etc, and when changing between in game menus etc. How could this have possiblly happened?

Link to comment
Share on other sites

Whenever I run into a glitch I remove the last thing I installed. Nine out of ten times, that fixes the issue. 

Always Aviate, then Navigate, then Communicate. And never be low on Fuel, Altitude, Airspeed, or Ideas.

phrog x 2.jpg

Laptop, Intel Core i7 CPU 1.80GHz 2.30 GHz, 8GB RAM, 64-bit, NVIDIA GeoForce MX 130, Extra large coffee-black.

Link to comment
Share on other sites

I have it narrowed completely down now. It isn't to do with the normal UK2000 scenery files, it appears to be specifically related to UK2000 HD Scenery only. The issue for now, seems completely fixed with no issues. I have reassigned my normal (legacy) UK2000 Scenery files, and it still works with no issues.

Link to comment
Share on other sites

11 hours ago, edwardstpowell said:

I have it narrowed completely down now. It isn't to do with the normal UK2000 scenery files, it appears to be specifically related to UK2000 HD Scenery only. The issue for now, seems completely fixed with no issues. I have reassigned my normal (legacy) UK2000 Scenery files, and it still works with no issues.


On a positive note, the issue did allow for some interesting screen shots.  😉 Glad you got it fixed.



Ernest Pergrem

System: i7-13700K, Gigabyte Z790 UD AX, 32GB RAM, GeForce GTX 1080 FTW Gaming, Windows 11 Pro 64-bit, MSFS 2020, FSX, Thrustmaster T.16000M Joystick, Cessna Pedals, Saitek Trim Wheel, Switch Panel, and Multi Panel

Link to comment
Share on other sites

Edwardstpowell, one really important piece of information from Event Viewer was missing - the exception code. With that, in addition to the name of the failing module, it is easy to find solutions by searching the web.

When I still had FSX, I also had all the UK2000 sceneries, and never had a problem with them, I must say.

And regarding the odd behavior of your AI aircraft - do they also "bounce" while on the ground? If they do, it is usually a problem with the [contact points] setting in the aircraft.cfg file.


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...