Jump to content

Looking for help with ntdll.dll issues.


Recommended Posts

Whenever I switch tasks, FSX crashes with an ntdll error. I've done lots of searching on Google, but more people seem to have the issue than be able to fix it. Any thoughts what I might be able to do?

 

Faulting application name: fsx.exe, version: 10.0.61472.0, time stamp: 0x475e17d3

Faulting module name: ntdll.dll, version: 6.3.9600.17630, time stamp: 0x54b0d74f

Exception code: 0xc000041d

Fault offset: 0x0001e193

Faulting process id: 0x12d4c

Faulting application start time: 0x01d0708aaeb159ab

Faulting application path: C:\MSFS\MicroSoft Flight Simulator X\fsx.exe

Faulting module path: C:\Windows\SYSTEM32\ntdll.dll

Report Id: 72e1eaa6-dc7e-11e4-829c-d050993b75ca

Faulting package full name:

Faulting package-relative application ID:

Spent way too much time using these sims...

FS 5.1, FS-98, FS-2000, FS-2002, FS-2004, FSX, Flight, FSW, P3Dv3, P3Dv4, MSFS

Link to comment
Share on other sites

Whenever I switch tasks, FSX crashes with an ntdll error.

 

Switch tasks?

 

Do you mean switching from FSX to another program?

 

Are you flying in Full Screen Mode?

 

If so, are you pressing Alt+Enter to switch to Windowed Mode before switching Windows focus to another program?

 

Ntdll.dll crashes are usually related to asking too much from your computer, meaning you need to turn down the sliders and/or turn off pseudo-ancillary programs running along side FSX.

 

peace,

the Bean

WWOD---What Would Opa Do? Farewell, my freind (sp)

 

Never argue with idiots.

They drag you down to their level and beat you with experience

Link to comment
Share on other sites

Yes, I like to do scenery and stuff, so I switch from full screen mode to windowed mode. I'll try turning things down a bit to see if it helps.

Spent way too much time using these sims...

FS 5.1, FS-98, FS-2000, FS-2002, FS-2004, FSX, Flight, FSW, P3Dv3, P3Dv4, MSFS

Link to comment
Share on other sites

Switching from full screen to desktop (task switching) is a problem for many people for different reasons. Differences in hardware and drivers contribute to this problem.

 

I personally switch between full screen mode and the desktop thousands of times a day without any crashes or problems. The same as you, I develop add-ons for FSX and have to task switch a lot during testing.

 

These may be the reasons I don't have this problem:

1) My Desktop and FSX are set to the same native resolution as my monitor.

2) I'm using an AMD Radion graphics card matched to an AMD mainboard chipset.

3) My DPI is set to default 100%.

4) I task switch carefully using this technique:

HOLD ALT key for three seconds in the sim, then while holding, *briefly* tap the TAB key.

 

-Pv-

2 carrot salad, 10.41 liter bucket, electric doorbell, 17 inch fan, 12X14, 85 Dbm
Link to comment
Share on other sites

At first I thought that I had fixed the issue, simply by lowering my LOD radius, but then the crashes came back. Still investigating. I wonder if disabling scenery areas might help.

Spent way too much time using these sims...

FS 5.1, FS-98, FS-2000, FS-2002, FS-2004, FSX, Flight, FSW, P3Dv3, P3Dv4, MSFS

Link to comment
Share on other sites

If your FSUIPC is up to date, the frame rate counter is a clue to if you need to lower settings. It's unlikely you have to change anything if your frame rates are "reasonable" (no lower than 10 at max load.) If you are able to get 20-30 most of the time, then processor load is probably not the primary problem.

 

-Pv-

2 carrot salad, 10.41 liter bucket, electric doorbell, 17 inch fan, 12X14, 85 Dbm
Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...