Jump to content

Logitech 52 pro stick and throttle cannot get it to work

Recommended Posts

Hello, i am having real and prolonged trouble getting my controllers to work. planes bounce off runway or building and tree on landings. i can only get some semblance of landings with AI co-pilot in control. I purchased Logitech 56 pro HOSTAS and had to send it back. I even tried editing the config files to change the values etc. still no good. My frustrations grows as i have yes to get control of any planes! Needless to says many sceneries and airports i have yet to experience. it seems like my controls are not connected to the planes or SIM? I am looking at the TCA system to see if that will work. I am reluctant to do so as the cost is so high! I used my Saitek 52 Pro stick and throttle fine with FSX but absolutely no success with MSFS2020. i need help to say the least.
Link to comment
Share on other sites

See posts #12 and #13 in this thread on the flightsimulator.com forums: https://forums.flightsimulator.com/t/logitech-saitek-x56-key-mapping-recommendations/282639/9

Tim Wright "The older I get, the better I was..."

Xbox Series X, Asus Prime H510M-K, Intel Core i5-11400F 4.40GHz, 16Gb DDR4 3200, 2TB WD Black NVME SSD, 1TB Samsung SATA SSD

NVidia RTX3060 Ti 8Gb, Logitech Flight Yoke System, CH Pro Pedals, Acer K272HL 27", Windows 11 Home x64

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...