Jump to content

Starting FSX error code 1-80004005

Recommended Posts

My FSX installation has worked faithfully for several years now.


Today, I started FSX and got the error code in the title. Apparently the registration information is gone, when I get to the selection screen, the Multiplayer option is greyed out.


Searching the Internet brought lots of info, including an often-mentioned way of running RegEdit.


Unfortunately, when I open the Registry key mentioned in that solution suggestion, the information that is supposed to be on the right-hand side is not there.


This is the old FSX DeLuxe plus Acceleration 3-DVD installation, in other words the two-step registration of first registering DeLuxe after its installation and then Acceleration after its installation.


Does anyone have a good suggestion here?



Link to comment
Share on other sites

Hey, I thought you might be coming up!


And yes, been there, done that and the problem is here:


3. After you find the folder, double-click Upperfilters on the right side.


On the right side, there is no "Upperfilters", just a big "nothing".




PS: Also tried the Flight1 Registry Reset tool, did not help.

Link to comment
Share on other sites



This is the MS advice but i am guessing you have been here too? If none of this works I can feel the dreaded uninstall/reinstall coming!!! It all points to FSX Acceleration by looks??

Good luck



Could try this maybe?



Edited by pomak249

i5 4690 (350mhz) with Arctic Cooler, 8GB Corsair Vengeance 1600mhz, ASUS Rock H97 performance MoBo, MSI Ventus XS OC 1660GTX 6GB, Windows10 64bit, 256GB and 500GB Crucial SSDs

Link to comment
Share on other sites



Yes, the first link was the first one I visited when I googled the problem, and it basically has the same advice as the link in your first reply.


The second link is for when a drive is not recognized - all drives are recognized, and FSX does run OK, but in the "pre-registration mode" with Multiplayer greyed out and a 30-minute time limit.


Thanks for your efforts -



Link to comment
Share on other sites

Jorgen - Hi, hate to hear of all your problems! Have you checked out the simliar threads/posts at the bottom of this discussion? Many have had this problem and it sounds like some have "happened upon" something that actually works? Check them out and good luck! :rolleyes:


Rick :cool:

Link to comment
Share on other sites

Fixed - now we're cooking!


I waded through a ton of threads, most of them actually had the registry hack, but as I said, that "Upperfilter" was not in my registry.


However, in one thread I found a reference to a txt file in the main FSX folder called "dlxkey.txt", which would house the product key.


So I looked in my own main FSX folder, and lo and behold, that file was there, but containing the text "product key here". Easy enough, I put the DeLuxe product key in there.


Looked around again (because this is Acceleration), and there was another file "Acckey.txt", also with the text "product key here". Acceleration product code in there, and try to run FSX. Same error. Reboot, same error.


Now, out of desparation, ran Regedit again. Hello, now there was something in the infamous key, and yippee, "Upperfilters" was there, containing "partmgr". Changed that to "PartMgr", reboot and ran FSX.


I have never, ever seen the registration screen come up and disappear again that quickly, maybe 2 seconds, but it ran, Multiplayer appeared, and I can run again as normal.


Thanks to everyone -



Link to comment
Share on other sites

Glad you got it fixed.

Thanks for sharing the solution, new to me.


Strange thing though.

I wanted to see how it looked in my install. I created copies of both those two files on the desktop (for safety) and then opened those copies. Both said: product key here. (No keys in were the files.)

Despite that my Fsx install runs fine and runs without time limit.


Are the keys still visible in your files now Jorgen? Or have they been replaced by the "Produkt key here" line again. (I expect they will be replaced because I think it would be safer not to have product keys stored on the PC. You want to keep those keys private.)

Link to comment
Share on other sites

Great minds think alike!


Strange days have found us...


Anywoozels, very glad it's activated again.

If my reply tempted you to try replacing it with the text again, for Frith's sake make a system image first!


Happy Flights, il.:D

Link to comment
Share on other sites

Jorgen, glad you got back airborne.. Thank you very much for sharing this extremely rare situation. This might ought to be put into a sticky.. Great find....tp

I9-10850K, Mugen 5 cooler, Gigagbyte Aorus Z490 Master, 2TB Samsung 980 Pro M.2, 1TB Samsung 970 Plus, 2TB Samsung 870evo, Corsair RM-850, G-Skill DDR-4 3600, Lian Li LanCool Mesh, Nvidia 3070Ti, Honeycomb Alpha and Bravo, MFG Crosswind pedals, Win10 Pro

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...