Jump to content

Need to replace Instant Scenery 3 What's avail. today?


Recommended Posts

Have lots of scenery objects and a good many acft objects created with the SAMM program which all worked well with IS3. Used it for years with Flt Sim 9, but after re-installing Windows 10, IS3 refused to open and only gave me the nasty "Invalid License" msg.


Wouldn't re-install either; tried buying a new copy from the website but it has a virus embedded in the download file and can't install; Flight1 stopped responding to queries about IS3 long ago and won't even answer the phone anymore :mad: (so to speak).


I'm stuck and need something else. Last Forum entries on this subject were long ago. Maybe new stuff is available to replace IS3 by now. Don't know. If nothing new, What will work with FS9 and where can I find it? :confused:


Any help out there?


Link to comment
Share on other sites

Well, nevermind. EZ Scenery is the answer.


The only one available on todays' market, as far as I can determine, is EZ Scenery from ABACUS. I believe it preceeded Instant Scenery, but now that Flight1 has decided to abandon their object placing app (which was far more user friendly as far as I can tell) EZ Scenery is the only one left that will do the job.


So I went to their website (Flight1) and bought it. Hardly any instructions as it's supposed to be intuitive: not quite but not impossible to learn.


In the end I have answered my own question, and maybe this will be of some help to others who want to populate an airport or airfield with bldgs, greenery, vehicles, figures, etc.

JonB :)

Edited by JonBuck
forgot something
Link to comment
Share on other sites

Interesting findings on your part.


My understanding was that EZ Scenery was killed off (reason unknown), and Instant Scenery 3 was the replacement. I believe both are the work of the same person/persons, but Instant Scenery 3 was an improvement over EZ Scenery.


I am using EZ Scenery in FS2004 on Windows 7. It's OK, but it keeps forgetting the registration details and you need to re enter them. Often. It is a known issue, and was never addressed. Not the end of the world, but a bit annoying nevertheless.



Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...