Jump to content

Stuttering Issue


class350

Recommended Posts

Hi, a few months ago FSX started stuttering. It happened randomly overnight. One day it was fine, next day it wasn't. No updates or anything that could alter my computer of FSX were done around this time.

The stuttering looks like the game is jumping around and merging/ghosting between frames weirdly, such that it bears resemblance to a very low frame rate (but a bit different) however my frame rate is at and always has been at between 30-60 fps on nearly max settings. Can anyone offer help?

I have already tried the following to no result:

 

Reinstalling FSX

 

Updating drivers

 

Lowering settings (resulted in higher frame rate, but fps was originally good anyway, and had no effect on the issue, which still remained even up into the 100s of frames per second)

 

Changing NVidia settings

 

Full screening the sim

 

Turning VSync on

 

Limiting the FPS to various values, both internally and externally of the sim.

 

 

 

 

 

Video attatched to show issue. It shows exactly how it appears in game and the effect is not due to compression of the video.

https://drive.google.com/open?id=1znPLIguSuKY5orvsvzMqfNhqrwPF7342

 

 

 

Thanks a lot, fsx is unplayable now!

Link to comment
Share on other sites

For a moment there I saw a graphic anomaly. So it could be with your GPU.

 

Did you install any add-ons prior to this happening?

 

 

Is this Windows 10?

 

Sometimes GPU drivers can be updated automatically by Windows or the GPU software its self. You may have a bad driver. Look for a driver that is withen the time frame of when there was no frame problem.

 

You shouldn't use high FPS settings. You want to give the CPU room to breath. Use a setting of 25-30 only and no more. I use 25 myself and your eye won't see a difference.

OOM errors? Read this.

"The great thing about flight simulation is that in real life there are no do-overs." - Abraham Lincoln c. 1865

An awesome weather website with oodles of Info. and options.

Wile E. Coyote would be impressed.

Link to comment
Share on other sites

Glad this came up, I too suddenly got a few stutters when everything was running smooth, but I remember getting a GeForce Gaming driver update a couple of days ago, anyone know how to roll back on that?

 

Col.

 

Just download the older driver. Then in safe mode on your computer use Revo uninstaller and uninstall the current driver. Reboot and install the old driver. Then go into the GPU control panel and turn off automatic updates. You may also want to read this and make damn sure Winblows doesn't mess with your drivers as well.

 

https://www.laptopmag.com/articles/disable-automatic-driver-downloads-on-windows-10

 

https://www.ghacks.net/2015/07/21/how-to-disable-driver-updates-from-windows-update/

 

Then after that you may want to stop telemetry from going to Nvidia. To do so add the following to your hosts file:

 

# nVidia Telemetry
127.0.0.1 gfwsl.geforce.com
127.0.0.1 gfe.geforce.com
127.0.0.1 telemetry.nvidia.com
127.0.0.1 gfe.nvidia.com
127.0.0.1 telemetry.gfe.nvidia.com
127.0.0.1 events.gfe.nvidia.com
::1 gfwsl.geforce.com
::1 gfe.geforce.com
::1 telemetry.nvidia.com
::1 gfe.nvidia.com
::1 telemetry.gfe.nvidia.com
::1 events.gfe.nvidia.com
#Geforce Experience installed
127.0.0.1 gfwsl.geforce.com
::1 gfwsl.geforce.com

 

Your hosts file is located in system32/drivers/etc or you can run Everything.exe and type in hosts and it will find it in an instant. https://www.voidtools.com/downloads/

 

You can optionally install Notepad ++ and then right click hosts and open with Notepad ++. Also chose properties of the hosts file and always mark it as read only after editing.

 

I shouldn't have to tell you that when you install a driver or even software for that matter is that you should select custom install and pick and chose what gets installed. In the case of the Nvidia driver, don't install GeForce Experience or what ever it's called. And if an option exists to search for automatic updates, uncheck that.

OOM errors? Read this.

"The great thing about flight simulation is that in real life there are no do-overs." - Abraham Lincoln c. 1865

An awesome weather website with oodles of Info. and options.

Wile E. Coyote would be impressed.

Link to comment
Share on other sites

Yeah, with software or drivers I always chose to not auto update and do so on my own and in my control. That way if something messes up I know what happened.

 

Looks like this link has an archive of older drivers. https://www.nvidia.com/drivers/beta

OOM errors? Read this.

"The great thing about flight simulation is that in real life there are no do-overs." - Abraham Lincoln c. 1865

An awesome weather website with oodles of Info. and options.

Wile E. Coyote would be impressed.

Link to comment
Share on other sites

Thanks Aaron, I sorted it, I forgot I have another uninstaller program, I went on that and it lists all the latest updates, I just deleted the driver in question, plus I had another program I no longer use that hasn't an uninstaller in it, this program I have deletes everything associated with the one I want to delete including any registration entries.

 

Col.

Link to comment
Share on other sites

For a moment there I saw a graphic anomaly. So it could be with your GPU.

 

yesm I forgot to mention that. It used to happen very occasionally at resource intensive locations if I panned the camera too fast, but It started happening way more often now, starting the same time the stuttering did. Certainly a possible solution, I'll have to look into that.

 

However, just to note, none of my other games have this issue. Does this rule out the driver problem or can certain games note like certain driver updates?

 

Thanks for getting back so quickly, I had no idea these forums were so active!

 

And yes, even when all was working fine, I had fps limited to 32, which gave smoothness but most importantly consistency.

 

I have numerous 3rd party airports and aircraft installed, but the most recent installation was months before the issue started, and it ran fine in that time, so it's not that.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...